Hello all. 

I've connected a Lightware SF10/c to my pixhawk serial 4/5 port as the instructions here show:http://copter.ardupilot.com/wiki/com...re-sf10-lidar/

My SonarRange is flat on 0. I can see that the unit is powered up because I can see the dot on the floor with a digital camera. I've triple checked continuity of the cable I made and I also (using the cable I made for the Pixhawk) with small jumpers stuck in the little connector, attached it to a USB to Serial adapter and with Putty I can see the distance just fine.

I dropped it down to 9600 baud, still nothing.

I'm new to pixhawk/apm world so I'm not really sure how to troubleshoot. I've double checked the wiring.

I currently am running firmware 3.3.2.

Lastly, this is still not done being built. This is my first experience with a Pixhawk. I'm upgrading from an Eagle Tree Vector. I'm not done rewiring. I am still waiting for a power module because I refuse to use the little 90A one that was supplied by 3DR. 

Thank you all.

Note (may be TMI): My parts list is as follows

  • Tarot FY680 Iron Man
  • Sigma Summit Motor Mounts (~740mm now)
  • PixHawk Controller
  • Mauch 4-14S 200A Power Module (pending delivery)
  • Quanum MT 3510 630KV
  • Turnigy K-Force 30A (Opto)
  • Zippy Flightmax 8Ah 6S 30C or Venom 6s 12Ah 30C
  • 13x5.5 Carbon Props
  • 3DR uBlox GPS/Compass
  • PX4FLOW Optical Flow Sensor
  • Lightware SF10-C LIDAR Altimeter 0-100m
  • Turnigy 9XR Pro
  • Floureon 915MHz Telemetry
  • 2W 1.3GHz NTSC Video Transmitter
  • HawkEye DTF-UHF 1w 16ch

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I would also like to add that I was having this exact same issue and the attached firmware did the trick so... thanks!

      • Hmmm...  Actually, this firmware is not working for me.

        To clarify:
        This firmware makes the Pixhawk play nice with the SF/10A that I have, but for some strange reason it prevents the arming of motors 5 & 6 of Y6B configuration. 

        It's pretty weird. 

        Now they may be only some correlation going on here but I've been banging my head against the wall today trying to figure out why two motors weren't arming anymore and one of the things I thought of was this firmware that was posted by Laser Developer.

        Reinstalling regular 3.3.2 brought back motor arming.  Installing Lightware 3.3.2-v2 removed the motor arming. Back to regular 3.3.2 once again brought the motor arming back, and finally reinstalling Lightware 3.3.2.-v2 prevented motors 5 & 6 from arming again.

        Very strange!

        Any input would be greatly appreciated!

        • Great to know. My setup is a hex too but not ready for flight. I'm still finishing off the wiring after upgrading to the PixHawk.

          • I have confirmed that the upgraded 3.3.2 I also lose channels 5 and 6.

            • Great, thanks for the info. We're looking into this ourselves to speed up a resolution.

              • The newest Beta firmware seems to work perfectly. All 6 motors and LiDAR all working. I think the version I installed was 3.3.3 RC1.

                • Got it, thanks. We're still digging through the code to find where the bug was hiding. 3.3.3 should include all the LiDAR features but we haven't yet verified what is available in each of the flight modes of this version.

        • Interesting. I can't take credit for this revision of software so I'll let the dev team know about the issue. Thanks for the feedback.

    • This worked. Thank you. Now is there any way to have this reading the default for altitude?

      • We are working on this and other LiDAR specific capabilities that we want to add to the code. I'll get back to you as soon as I have a firm completion date. Would you be open to testing the code for us?

This reply was deleted.