Loading code with MP works, but prompt line still shows former code version

I just got my APM two weeks ago.

Read though all the wiki and loaded the arducopter code 2.0.39 beta. It was the code which was available at that time through the mission planer.

Now the latest one is 2.0.40, at least that's what the mission plans says. When I try loading this code it works fine without any error messages. In fact only one warning at the beginning, that the eeprom format changed and I will loose all my data on the APM. I accepted it by proceeding

When I connect to the APM with the CLI after the code upload, the prompt still says: AC 2.0.39 beta, and not 40.

 

I do not think this is normal.
Anyone any hints what the problem could be?

I already tried erasing the eeprom and resetting it with the CLI. Makes no difference.

 

Thanks.

Views: 345

Reply to This

Replies to This Discussion

Outside of this issue itself, you will first want to update Mission Planner manually to 1.0.68, the most current version. Do not use the built-in updater, as this will not work for you. The project was moved from Subversion to GIT, and so the version of MP you have does not update and does not see the new firmware.

 

You can download the new Mission Planner at http://code.google.com/p/ardupilot-mega/downloads/list

 

Give that a try first, and you will see 2.0.42 firmware. It has some important fixes that you will want. See how that works before spending too much time troubleshooting the issue you described. 

Ok, tried that.

Now MP really offers to load AC 2.0.42.

Result still the same. I get a warning that the eeprom format changed, I accept, it loads the code, verifies, and says all ok.

Connecting the CLI, the prompt still says AC 2.0.39 beta.

 

Is there any other way to reset or erase the eeprom?

Has anyone seen these warnings with the eeprom format before?

I have never seen that. 

 

I can report that mine does not behave that way:

 

Init ACM
RAM: 2574FW Version 107----------------------------------------


Entering interactive setup mode...
Type 'help' to list commands, 'exit' to leave a submenu.Visit the 'setup' menu for first-time configuration.
ArduCopter 2.0.42 Beta]

 

Something (beyond my expertise) is not right. 

If I were in your shoes, I would load up the Arduino IDE, set for the serial port and the right board, then load in something like the "blink.pde" example code, or MultiSerialMega.pde or similar. If that worked, then I would close out the Arduino IDE and fire up Mission Planner again, and tell it to push the firmware again. I would skip using CLI mode at all, until after the setup was complete, with a manual "erase/default" settings just in case, then stepping though each of the setup steps, from radio to AC2.

 

But that is just what I would try. I have no idea why this is happening.

Thanks for the hints.

Uploaded some of the test programs to the board with Arduino 22.

Everything works fine. Codes are running.

However loading AC 2.0.42 beta with the mission planer gives me the same prompt again: 2.0.39 beta.

I can only imagine, that MP in the background somehow uploads the former version. Because something is uploaded, otherwise the demos I loaded before are gone and replaced by 2.0.39 beta.

 

I would like to upload 2.0.42 with Arduino, but I am failing as I get tons of compilation errors. I did exactly as the wiki says. Setting the right sketch folder and so on.

As far as I interpret the error messages, it is an issue of finding the library files.

Get messages like fastserial.h not found, etc.

 

I am really puzzled.

If someone has a good idea how to solve the compiling issue, I might have a chance to upgrade to 2.0.42. Then it would be definetly an error of MP.

Christoph: I just checked and it looks fine here. Are you using the latest version of the Mission Planner 1.0.69)?

 

It's not solving the issue.

Please see attached pictures.

Why does mine show less ram and another FW Version?

 

I did check: I got the ATMEGA 2560 on my board.

Attachments:

I have a v1 APM and upload via Arduino. The latest firmwares (40, 42, except I haven't tried .43 yet) all stick me in an endless loop of erasing EEPROM. Upon entering CLI it detects a firmware update then erases EEPROM. Then I reset the board to defaults, reboot and then via CLI I am prompted to erase EEPROM due to firmware update again. So, it's not just Christoph...

 

John, you are saying you upload via Arduino.

So for you compiling must work at least.

Any idea why I can not compile the latest 42 firmware from the wiki download area?

Christoph: are you sure the code is loading? Do you get a "Done" at the end? 

It compiles fine (I just checked). If it's not working for you, you've got your preferences wrong in Arduino and it can't find the libraries. Make sure the preferences are pointed to the folder that holds both the code folder and the libraries folder. 

For example:

 

ArduCopter 2.24  <---set preferences to this one

--ArduCopter

--libraries

 

But unless you're modifying the code for some reason, you shouldn't be using Arduino. The Mission Planner is the foolproof way to load the code.

 

Solved!

Lucky day.

 

1. Should be corrected in the Wiki and manual:

The code will only compile when the libraries are copied to the Arduino/library folder! When I installed arduino, there is a library folder in the install folder. Just add the libraries coming with the arducopter zip to that folder and then it works.

If they are just in the folder as you described above and as it is described in wiki, it won't work. Even if the sketchbook folder preference is set!

 

2. Loading the code 2.0.42 with arduino gave me now the correct prompt in CLI!

So I really had an issue even with the latest MP! It doesn't load the latest code. It says so, but in reality 2.0.39 was there again.

Sorry to say, but foolproof in my case was finally the arduino way.

 

I am happy, because at least it wasn't a problem with the hardware.

Yes, I always got a "done" at the end.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service