loiter mode causes copter to drift away fast

everything was working fine quad flew great,,,now if i go into loiter mode it rolls right every time,, alt hold works using gps??, also had problem after flying a bit i tried auto calibration and cant even control it in autosetup mode,,,going to check compassmot when batts recharged, just to see where that is now..

any body else having this problem or know how to fix it,,,,,i allready did a full wipe and firmware load

then all setup steps ,, the only difference is i flashed my esc`s with simonk

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • i dont get it with mavlink i can watch my quad fly see where it took off from and see its motion on map in MP i will be flying it is very stable autotune mode worked this time,, if i go to loiter mode i can watch it slowly take off on screen ,,so it knows where it is but it doesnt want to stay there so i have to put in stabalized mode

  • compassmot 20% i tested gps in terminal i looked in logs it always at least 6- 8 sats, i have to try auto trim tomorrow again,, i wiped eprom reloaded firmware 3.0.1 set everything up and will try doing auto trim again after i fly it around a bit

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25