Magnetometer initialisation failed

I've just installed my old APM/IMU/Magnetometer from my Arducopter into my Skywalker and installed the  latest APM code.


During testing I found that the AH wasn't displaying heading, and I've checked the hardware setup screen and confirmed that compass is enabled with declination set.


I've then gone to CLI and tried to run compass test, and it reports that the compass of off.


I then goto setup and give the command compass on


It reports initialisation failed.


I'm sure it was working on my Arducopter.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi, I need a help regarding to my mag sensor. I connected the Mag sensor to IMU sheild based on method 2 given on the website. I am pretty sure about the wiring and I have uploaded the arduplane code v 2.3 through adruino IDE.

     I've then gone to CLI and tried to run the compass test from setup, and it reports that the compass initilaization failed. I cannot enable the compass, seems the board does not recognize the mag device. Any idea how can i debug this. thanks



  • Developer

    @Hai, I fixed a bug that could cause this for a 5843 magnetometer yesterday. Are you using the latest svn, or a hex release?

    Also, is this a 5843 or 5883L mag?


  • 3D Robotics
    Did you load the code through the Mission Planner?
This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25