MAVLINK errors on one PC only

So as of yesterday I am unable to make a MAVLINK connection through my telemetry gear, but only on my laptop.  When I hit connect (yes, port and baud rate are right, CLI switch is in the flight position) the connection window immediately disappears without counting down a timeout or displaying the "get parameters" screen.  About 15-30 seconds later I get the following error message:


System.ArguementException: offset and length were out of bounds for the array or count is greater than the number of elements from index to the end of the source collection.

at ArdupilotMega.MAVLink.Open(Boolean getparams)

as ArduPilotMega.MainV2.MenuConnect_Click(Object sender, EventArgs e)


This occurs only on my laptop.  With the telemetry gear plugged into my desktop PC it works fine.  The laptop also worked fine previously, and I have made no changes to its hardware since then - I assume it's something to do with the latest planner but not sure.


I have tried reinstalling both the current (.14) and beta (.17) FTDI drivers from the link provided in the wiki.

I have updated MIssionPlanner to the latest and have tried to connect to both ArduPlane and ArduCopter, both with the most recent firmware.


Any thoughts?  If only I could bring my desktop to the flying field...  :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21