MAVProxy Problem: fail to load params file

Hi,

 I'm trying to use dronekit-python and am currently setting up SITL on windows, following the instrcution as below:

 http://dev.ardupilot.com/wiki/sitl-native-on-windows/

 I've installed MAVProxy and Cygwin, downloaded all the files and have made them without any errors. But when I started MAVProxy and trid to move on, I got a problem with this step in the instruction:

"Configure the vehicle by loading some standard/test parameters into the MAVProxy command prompt:

param load ..\Tools\autotest\copter_params.parm"

The command prompt of MAVProxy  reported an error : "failed to open file '../Toolsautotestcopter_params.parm' ".

Then if I try to move on to the next step, which is "Change to GUIDED mode, arm the throttle, and then takeoff", the copter won't take off due to "RC not calibrated".

I've tried removing all the files and started over, but same problem occured.

Has anyone seen this problem before? Could anyone help me out here? I'm not good with cygwin, and I couldn't identify the problem

Thanks A LOT!

Daqian

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  •  I had the same issue. Fix by using forward slashes "/" in the command.

    param load ../Tools/autotest/copter_params.parm

    • Hi Warren!
      Thx for replying. Will try that later. Pretty sure it would solve my problem! I was so silly didn't even check the path LOL
      Regards
      Charlie

  • Just checking the obvious but with the error:

    reported an error : "failed to open file '../Toolsautotestcopter_params.parm' ".

    It looks like you didn't add the '\' to the path and it was looking for the ../Toolsautotestcopter_params.parm file in the current directory.  Ensure you are actually typing the forward slash.

  • Developer
    Start sitl using the sim_vehicle.sh script in the directory of the vehicle you want to simulate. I.e. /ardupilot/ArduCopter and the first time you run it use the -w to initialize the parameters for that vehicle.

    You also, once running, need to set ARMING_CHECK TO 0 to avoid the RC calibration warning..
    • Hi Bill,

      Thanks for replying!

      I do use the correct sim_vehicle.sh script every time, and I've tried setting ARMING_CHECK to 0. It worked! Thanks a LOT!

      But the params loading still fails. Could you please be more specific about the ' -w ' ? I'm sorry I don't really understand.

      Again, thanks for your great help!

      Regards

      Daqian

      • Developer

        i use 

        sim_vehicle.sh -w --out=10.0.1.17:14550

        That just resets the EEPROM to defaults on start, you only need to do it once, next run would be

        sim_vehicle.sh  --out=10.0.1.17:14550

        if you want you can add locations to Tools/autotest/locations.txt and start in your location

        sim_vehicle.sh -L GLEN --out=10.0.1.17:14550

        where i added the line

        GLEN=49.249581,-123.082972,20,260

        The last two params are start alt in metres and heading in degrees

        • Hi Bill Sorry to bother you again, but I've got a new simple problem. I'm actually kinda new to this world of MAVProxy, Python and dronekit. My MAVProxy has not yet been compiled and copied into my Python directory, and I have two questions here:

          i.  The tutorial says that I should start MAVProxy by entering some command line like 'mavproxy.py', but I do not know where to enter it. Do I enter it in python shell?

          ii. The tutorial also says that I have to install something, with at first a command line like 'cd path\'. Again I'm confused where should I enter this line, in the shell or IDLE? They both seem to deny the cd command.

          I'm sorry if these questions is to lousy for u to answer, I just got started with these and a lot of new stuff puzzles me. Please help me if you have some time free, I kinda got stuck here lol.

          Regards!

          Daqian

        • Thanks for replying again!

          I've went through your instructions, but the MAVProxy still fails to open the .parm file.

          But there seems not to be any problem, and I don't wanna bother you any further.

          Anyway thanks again! Great Help!

          Daqian

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Sync'd @joshu's GoPro w/ my datalogging; video is 2.5X speed, Google imagery upper-right. Found out my track boundaries are WAY…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Also, at 45mph, the front tires literally blow up like a balloon and it doesn't have much front traction, so the car becomes fai…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Okay, some datalogs! Green dots are precalculated racing line (from my crummy optimizer -- it veers to the middle after 2 for Re…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Welp my @selfracingcars entry, hastily conceived heading filter and all, actually worked! Heading home, datalogs and videos to f…
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @f1tenth: What can we learn from autonomous racing? Actually, a lot! To get an idea what you can do in this field and where the research…
Oct 11
DIY Robocars via Twitter
Oct 11
DIY Robocars via Twitter
RT @a1k0n: It's aliiiiiive! Less than a week until @selfracingcars and I'm just now digging this bad boy out. Been a crazy few months. Hope…
Oct 10
DIY Robocars via Twitter
RT @OttawaAVGroup: Mark your calendars. CAV Canada is happening on Dec. 2nd, 10am-4pm EST. And guess what - admission is FREE! Get your ti…
Oct 6
DIY Robocars via Twitter
RT @f1tenth: Our new 1:10 scale 3D racetrack is here. We will implement it in the @SVLSimulator in the next weeks so everybody can use it.…
Oct 6
DIY Robocars via Twitter
RT @DAVGtech: Received sweet autonomous Ferrari's that we plan to demo at the @IndyAChallenge on our portable @donkey_car track. Let us kno…
Oct 6
DIY Robocars via Twitter
Sep 30
DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
More…