Has anyone else had their MediaTek GPS lock up, refuse commands, and send unrecognizable garbage?

While working to track down the "longitude error when in binary mode" bug, I noticed that my GPS would suddenly stop sending NMEA text messages and send garbage. Cycling the power sometimes fixed it. Letting it sit a while sometimes fixed it. Usually it took several tries to get it going again. 

Symptom #2 is that instead of blinking at 1Hz (while trying to lock) or being solid on, the blue LED on the GPS will blink much slower. I'd say 0.5 Hz.

Symptoms are the same when working on a PC or a Mac, using a 3V or a 5v FTDI cable. Affect both my MediaTeks.

Anyone else? 

And a ps to Jordi: You may have a battery issue or a battery killing process issue. When I started seeing this I checked the back up battery voltage, one GPS was just 0.17 volts, the other was 2.97 volts. These units arrived less than a week ago. 

I pulled the dead battery and ran a jumper from pin 1 (Vcc) to pin 4 (Vbackup) since the docs say in red that Vbackup must be present. That unit "resets" sooner than the unit with a battery, but also fails faster.

Here is a trimmed log of the output, right at the point where it locks up.


Views: 408

Reply to This

Replies to This Discussion

It also happens whether the unit has a fix or is still acquiring satellites.
The one I got 8-26-2010 doesn't work. The blue light lights yo VERY dimly.
Hi there,

If you have faulty GPS return it! Just contact sales@storediydrones com and ask for RMA because your GPS is not working properly...

There's an issue on the firmware that we correctly working on and you can update it at home.
Hi Jordi,

Is the issue with the firmware that you are working on related to the problems described in this thread here? It would be great if you could tell if there is (or will be) a new version of the firmware that solves this problem.

Hi, my name is Enrico an i'm writing from Rome, Italy. I'm a new user.
Several days ago i bougth from DIYStores a pcb called "MediaTek MT3229 adapter" ( http://store.diydrones.com/product_p/br-0014-01.htm )
It's the same pcb you used, but over mine i did soldered a GTOP FGPMMOPA6E.
After the first GPS Fix i get the same error ( correct NMEA followed by strange characters). Now the blue ligth blink dimly, no way to receive prompt, no answer all. I tryed every speed and COM setup.
Any other suggestion ?
I'm sorry for my bad English,
Tks, Enrico.
Hello. I made another test.
I fully discharged the battery by a 10Kohm resistor, i powered up the chip. The blue led ligths was fix and high, then power off/on and the light was falling dimly again. So i added a 100 nf cap. between 5V and GND pole and i added a ferrite ring to the cable, but nothing new appends. When I touch with my finger the zone around the five pins chip (the voltage stabilizer i suppose) the led turs brigth & fix again. May be a GPS chip fault or the pcb have some oscillation?

What's your experience about?

Tks, E.
Check the power to the GPS. Spec is 3.2v. All the units with problems have a Vcc of under 3.1v.
If your adapter board is the one that comes with a MediaTek when you buy them as a pair at the DIY store, then you probably have a weak power supply. Make your own 3.5v power supply and use that.
If you completely discharged the battery, you have ruined it. What are you trying to do with all that?
Hi Ken, my GPS chip come from GTOP industries and it's fully MTEK compatibile (the same datasheet). I soldered over the DYIDrones pcb. Power is ok with no ripple at all. May you kindly explain to me why it's no a good idea to discharge a battery?. I done that becose i want to reset it to factory setting.

Thanks for you time, Enrico.
Rechargeable batteries have a minimum voltage (the specific voltage depends on technology/chemistry) below which permanent damage occurs. This damage may manifest itself as failure to accept a charge, reduced capacity, or explosion/venting on recharge.

Capacitors can be completely discharged by a resistor. Batteries must be monitored and never let go below the manufacturer's minimum voltage.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service