I have been using this with the extra versions for a few months.. It was pretty stable, but now after moving it to another plane, it is acting weird.  I was using firmware R139 or something like that and it was fine in my bixler.

moved it to skywalker and it shuts off when I toggle through different flight modes.  I have now installed version 2.1 and same behavior. I tried disabling the mode switch and still no change.

Once it shuts off it will not come back by toggling... only by rebooting.

It boots up fine and seems to be fine until I switch modes It seems to do when I switch modes fast.  not all the time but a lot.

I power it from the APM side with the 2 solder blobs installed.. only have video in and out.

Any ideas why this is happening?  IS my osd dead?   thanks for any suggestions.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Mack,
    Did you find out why?
    I have the same issue..
  • Sorry I meant to post this in the thread that discusses this project!

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Wednesday
gotham liked gotham's profile
Dec 3, 2020
More…