Mission Planner 1.2.82 Wireless Connection Issue

I have had a very frustrating weekend working on my Octorotor.  I ran into some strange issues with Mission Planner and wireless telemetry.  

I had not flown my Octorotor in a while, so I started with the same configuration that I had previously flown (APM2.0 with 2.9.1b firmware). I pulled everything out, set it up, and started testing.  I updated Mission Planner when it suggested that I do so.  Then, I turned on the Octorotor and connected over wireless telemetry with no issues. I flew a couple of times in this configuration.  I then started making some modifications to the camera setup.  I headed to bed and woke up this morning looking forward to a fun day of flying.  I tried starting Mission Planner and it would not start.  I kept getting an error that just gave me the option to close the program or let Windows search for a solution.  No big deal, I checked the forms and uninstalled and reinstalled.  Mission Planner now started, but this was a short lived victory because I have not been able to get the wireless telemetry working since this latest installation. It keeps getting stuck saying "Getting Params.. (sysid 1 comid 1)" and nothing I have done has chanced this situation.  

I have now updated to 3.0.1 firmware spent many hours testing each piece of the hardware puzzle isolated from the rest of the system and even beat my head on a table a few times for good measure, but nothing has brought back wireless telemetry.  I have read every article I could find on this issue (most citing the same error) and tried everything that was suggested in these articles, but nothing has fixed my problem.  After spending all day testing, I am confident that the problem now lies either with Mission Planner or APM2.0 and is most likely a software issue (all of the hardware checked out multiple times in multiple checks).    

Things that are working

  • The Octorotor is flyable using my Futaba transmitter (Stabilized and Alt Hold tested so far with new firmware)
  • The OSD is working (I am receiving the live telemetry updates on the video)
  • I can connect to the APM in Mission Planner over USB

Here is the setup that I am working with right now

  • APM 2.0 running the latest 3.0.1 firmware
  • Mission Planner  1.2.82 build 1.1.5033.11289
  • Windows 7 Ultimate x64
  • Lenovo Laptop
  • Express Card Dual Serial Adapter
  • Digi Extend 900MHz serial modems
  • MinimOSD
  • 5.8GHz Video Transmitter
  • GoPro HERO 2
  • Futaba Receiver

I have included a link to a video I recorded of the connection process and the error that I got at the end of it.

http://youtu.be/Ktgf6trEXiw

I am not new to UAV's and have an extensive background in this area, but I have reached the limits of my skill set, I am not a programmer.  =)  Please, if anyone has seen this issue and has any more suggested solutions I can try or if anyone can look into this issue from the software side it would be greatly appreciated!   

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    skydog,

    the mission planner isn't getting 2 way comms. data is getting to MP but data MP is sending is failing to get to the AP.

     

    Check the connections.

  • Developer

    in MP folder.

    delete ArdupilotMegaPlanner10.exe.config

    and it will be fixed

  • Moderator

    There was/is a problem with the v1.2.82 update of MP, starting with the program crashing on start (http://diydrones.com/forum/topics/just-updated-mp-and-now-it-crashe...).

    I fixed it by downloading the latest version here then deleting the contents of "APM Planner" folder but not "gmapcache" and "logs" and anything else I created in it and then copying the contents of the downloaded zip back into the "APM Planner".

    From that thread though the fix is to start "missionplanner.exe" and not "ArdupilotMegaPlanner10.exe"

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…