Mission Planner 1.2.82 Wireless Connection Issue

I have had a very frustrating weekend working on my Octorotor.  I ran into some strange issues with Mission Planner and wireless telemetry.  

I had not flown my Octorotor in a while, so I started with the same configuration that I had previously flown (APM2.0 with 2.9.1b firmware). I pulled everything out, set it up, and started testing.  I updated Mission Planner when it suggested that I do so.  Then, I turned on the Octorotor and connected over wireless telemetry with no issues. I flew a couple of times in this configuration.  I then started making some modifications to the camera setup.  I headed to bed and woke up this morning looking forward to a fun day of flying.  I tried starting Mission Planner and it would not start.  I kept getting an error that just gave me the option to close the program or let Windows search for a solution.  No big deal, I checked the forms and uninstalled and reinstalled.  Mission Planner now started, but this was a short lived victory because I have not been able to get the wireless telemetry working since this latest installation. It keeps getting stuck saying "Getting Params.. (sysid 1 comid 1)" and nothing I have done has chanced this situation.  

I have now updated to 3.0.1 firmware spent many hours testing each piece of the hardware puzzle isolated from the rest of the system and even beat my head on a table a few times for good measure, but nothing has brought back wireless telemetry.  I have read every article I could find on this issue (most citing the same error) and tried everything that was suggested in these articles, but nothing has fixed my problem.  After spending all day testing, I am confident that the problem now lies either with Mission Planner or APM2.0 and is most likely a software issue (all of the hardware checked out multiple times in multiple checks).    

Things that are working

  • The Octorotor is flyable using my Futaba transmitter (Stabilized and Alt Hold tested so far with new firmware)
  • The OSD is working (I am receiving the live telemetry updates on the video)
  • I can connect to the APM in Mission Planner over USB

Here is the setup that I am working with right now

  • APM 2.0 running the latest 3.0.1 firmware
  • Mission Planner  1.2.82 build 1.1.5033.11289
  • Windows 7 Ultimate x64
  • Lenovo Laptop
  • Express Card Dual Serial Adapter
  • Digi Extend 900MHz serial modems
  • MinimOSD
  • 5.8GHz Video Transmitter
  • GoPro HERO 2
  • Futaba Receiver

I have included a link to a video I recorded of the connection process and the error that I got at the end of it.

http://youtu.be/Ktgf6trEXiw

I am not new to UAV's and have an extensive background in this area, but I have reached the limits of my skill set, I am not a programmer.  =)  Please, if anyone has seen this issue and has any more suggested solutions I can try or if anyone can look into this issue from the software side it would be greatly appreciated!   

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    skydog,

    the mission planner isn't getting 2 way comms. data is getting to MP but data MP is sending is failing to get to the AP.

     

    Check the connections.

  • Developer

    in MP folder.

    delete ArdupilotMegaPlanner10.exe.config

    and it will be fixed

  • Moderator

    There was/is a problem with the v1.2.82 update of MP, starting with the program crashing on start (http://diydrones.com/forum/topics/just-updated-mp-and-now-it-crashe...).

    I fixed it by downloading the latest version here then deleting the contents of "APM Planner" folder but not "gmapcache" and "logs" and anything else I created in it and then copying the contents of the downloaded zip back into the "APM Planner".

    From that thread though the fix is to start "missionplanner.exe" and not "ArdupilotMegaPlanner10.exe"

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
19 hours ago
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
19 hours ago
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…