Does anyone know what changes were made in the latest MP?

There isn't anything listed in the change log.

https://github.com/diydrones/MissionPlanner/blob/master/ChangeLog.txt

I see there are some changes to the accelerometer calibration. An additional step to calibrate level is added. Doesn't calibrate accel do the level calibration as well?

I'm concerned because I successfully flew a short auto mission on Wednesday, but did the exact mission on Thursday with some issues.

The two differences between the the flights were I updated MP and ran the new calibration (both accel and level) and added a canon a2500 camera mounted directly in the center, bottom of the aircraft. There was a bit more wind on Thursday as well. 

I basically took over after climbing out to the first waypoint because it didn't "feel" right. Maybe all is okay, but I'm paranoid. 

Auto Analysis showed some warnings too: 

Test: IMU Mismatch = WARN - Check vibration or accelerometer calibration. (Mismatch: 0.89, WARN: 0.75, FAIL: 1.50) 

Views: 1035

Reply to This

Replies to This Discussion

I re-calibrated the accel on a PC running 1.3.30.

Flew the same mission that was previously loaded on Pixhawk. 

No payload. 

No issues. 

I'm not sure if this is a fluke or not, but seems there may be somthing wrong with MP 1.3.31 accel calibration. Or perhaps the payload is inducing too much vibration...

Going to add payload and fly same mission, hopefully this afternoon. 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service