Howdy all,

I just cloned the mission planner and was working on getting it to compile (visual studio 10), when I ran into a problem with SharpKml.dll

The file currently in source, appears to conflict with Netframe 4.0, and when I downloaded the lastest version (from codeplex), I end up with an invalid argument error in MavlinkLog.cs


Guess I could do some reading about the SharpKml project, and debug myself, but given there is a working build (I know cause I'm using it :) ), figured I just ask whats up ???



Views: 823

Reply to This

Replies to This Discussion

BTW it build's fine under 3.5 framework, but the Wiki suggests 4.0 framework required.


currently its compiled under 3.5, it use to be 4 for a ltitle while, but went back to 3.5

Ya, works fine for me under 3.5, thanks, nice code base,

I'm adding a new frame type, and figured I may as well change Planner at the same time.





Is there a wiki somewhere that details how to configure the VS projects to build the mission planner? I have checked out the missionplanner from github, added reference paths to the Lib folder, and disabled signing in all projects in the solution, but now I have these two errors that I can not solve.

Any help is appreciated.


Best to ask Michael, my current version compiles fine with 3.5 .Net, not sure where his version is ATM, both errors above are .Net related, and likely the source of your issues


rebuild all the other library included as well, should fix it.

I changed all the projects to use .Net 3.5, cleaned, rebuilt, and still get the same 2 errors.

Also, the readme in the repo says to change the reference path to "the installed mp directory". Shouldn't the path be set to the /Lib folder in the repo? This is where they all get built to, right?

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service