Mission planner HUD horizon inverted

Hi. Help please. I am setting up a Crius AIOP v2. I ran the arduino configuration for Megapirate. It is plugged into Mission planner and the horizon is inverted. When I tilt the board it settles back into this same position regardless of how it is tilted, but the compass is correct. "Russian HUD" makes the sky blue and the grass green, but the inclination and roll marks are still inverted. I ran the accelerometer calibration. Screenshot attached. Did I miss something in the setup somewhere?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • So regardless of how you tilt it it does this? Sounds like bad gyros on the board. You can verify this by loading MW 2.3/2.2 and see if it behaves the same way. I am sure you know the Ardupirate firmware is a little old now, and the last version is a little questionable, stability wise. (I use my AIOP only for MW2.3).

    • Thanks.

      Since posting I reloaded megapirate and it seems to be OK now. I think the problem happened when I copied my settings made in mission planner on another board I have set up successfully over to the new board. Something must be different between the boards. The one thing that still bothers me is that it is still slightly off of level - close, but off. I hope it's not enough to matter.

This reply was deleted.