Mission Planner Mavlink Won't Connect (No Heatbeat Packets Received)

MP connected and downloaded firmware to the APM 2.5 without issue.  But when I click the upper right Connect to get the parameters:

o When the USB is plugged in, COM4 Adrino Mega 2560 (COM4) appears [device setting is 115200 as is the MP pulldown]

o When click Connect

   - MP sees the connection and it starts to connect

  -  APM blue light 3 times, red flashes twice, yellow light flashes, green is solid 

o Then countdown to "No Heatbeat Packets Received"

  - orange light stops

  - green stays solid

o Under details, the following is shown.

I might be just tired, but can anyone help?

I'm powering via the USB.  Nothing but the GPS/Mag and radio is powered by the APM (disconnected the receiver and ESCs).  I've tried adding battery power, reinstalling the firmware (does that part just fine), differnt USB ports, restarting my computer, ... 

Views: 15218

Reply to This

Replies to This Discussion

@Forrest Frantz

it happens to me when:

I connect using a usb cable with CLI and then after clicking the [disconnect] button in the CLI I try to reconnect with mavlink.

Then I got the same problem. (Windows 7).

My Solution:

1) Disconnecting the USB plug from the APM and power if connected to a battery.

2) Shutdown Mission planner on the PC.

3) Re connect The USB cable between the PC and the APM

4) Restart Mission planner software and connect 

Then everything is ok again.

Hope this helps


Thanks Henri.

Tried that.  Even restarted my computer ... resetting the APM ... independent power ...

Sure is odd that I can upload the firmware with no problem in MP.  It also appears to connect in terminal mode but in CLI I don't get a response when I try to do a Log then Enable RAW.

I might just scrap the board and try the PixHawk.

Hi Forrest,

Before you dump the board, maybe try to reflash the ppm encoder that apparently also manages the USB connection:


Or you could also try to connect via radio telemetry?

Your advice is always top notch.  Definitely have not tried that yet and it looks hopeful.  And will do so because I can use that module on a play copter for friends.  At least if that doesn't work, i'll be pretty sure that it's hardware.

I took the 2.6 issue as a sign from the multirotor gods that the world endurance record needs to be broken with the PixHawk.  Guess I owe it to 3DR to at least try as they push the technology (don't want to do it with old technology).  It weighs 8 grams more stripped (14 grams more out of the box), so don't know if it can be done as the ship will also be carrying a camera and now a buzzer, failsafe switch, encoder, etc.  Maybe the faster processor makes the ship more efficient?  I can only hope.

Thanks again.

I am smiling alone with a crazy idea: to compensate for weight, why not add an helium filled balloon on the multicopter lol

LOL!!!!........ maybe 2? 

actually there was a recent post here a few days ago on diydrones of a Düsseldorf company who has a project to install an autopilot on a blimp. It looks quite interesting to me and have taken contact with me.

Seriously, if someone could design a propeller cage made from rip-stop nylon and helium that was weight neutral, it might sell. 

Hi gents, APM newb Gustav here............., excuse the light intro and truly Sorry for barging in on this but the post by Forrest led me here.

First APM 2.6 board I set up this weekend seems to be exhibiting the textbook  cooked  3.3v Regulator behavior.........my conclusion after 2 sleepless days.

Overview of steps i.e. physically hooked up the GPS, went through the drill in Mission Planner,  downloaded the FW, got the Mavlink Heartbeat error or similar one in Forrest's description.

CLI gives no joy like "no data flash inserted" + setup throws "failed to boot MPU6000 5 times"

Post about this seems to be closed due to people getting jiggy with each other,  so if you are open to vocalising  some seasoned advise im looking for a seasoned opinion

What I see is either send a team of nano-bots over to the board and swap the regulator or wait patiently for the reputable vendor to reply after clearing a likely backlog of email from after a  long weekend.

Don't want to due any more possible damage but is there anyway to be sure that the only or root cause of issues is a blown regulator?




Hi Gustav,

Have you !measured with a multimeter that you do not get 3.3V to be sure you have a blown regulator? You can measure that with the two extreme pins of the I2c connector (the one just next to the power module port)

If it confirms it is blown, you will have no choice than to replace this regulator but it it a tricky job.

Have you tried a different USB cable?
What about connecting via telemetry to narrow things down a bit?
My old APM 2.0's have been through the ringer and often have USB connection problems. Telemetry to the rescue!

Thanks Ted.  Yes, but the following is more background.

It connected once fine with the GPS/Mag and radio connected.  Then I connected the receiver.  What I saw was the board appeared to brown out (a couple blinks and then off each time I tried).

After that, it stopped communicating via Mavlink (reciever connected or not) but still communicated via MP firmware upload.  I tried connecting battery power to supplement power via the power module.  The behavior didn't change (lights went woud blink a few times and then go out if i connected the receiver and the added power didn't help Mavlink even when the radio wasn't connected).  The receiver power was connected via the receiver input +/- pins w/ red going to the middle pin, ground on the outside pin, and the channels to the inside pins (pin orientation upwards).

Any other ideas, let me know as I'll get back to it when i build the "friend" copter.  

I haven't tried communicating with it via radio.  Was going to but made the decision to fly the PixHawk instead.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service