Mission Planner Problems

Hello Everyone,

 

Ok I have a challenge that does not make any sense.  I connect my APM 2.5 to the PC and start the mission planner and it claims they are connected BUT I am getting zero readings off the quad with the data or config tabs.  No GPS no compass, no radio controls yet if I go into the terminal settings and test the gps or compass it reads it just fine.

 

It allowed me to download and install 2.9.1b but still nothing.  On Top of that all of my motors are beeping like they are not calibrated.

 

First I thought it was a radio connection but the board will allow me to arm with the controller.

 

This is very frustrating any help would be awesome.

 

 

Jason

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Jason,

    I installed and configured the second APM I had ordered and it is working perfectly. This just proves what I already suspected, the first APM is defective.

    Steve

  • Do you have a 3DR Telemetry radio connected as the same you plug the USB from the PC into the AMP?  If so, try unhooking it.

  • Jason,

    My APM worked less than a day with the 2.9.1b release.

    I spoke with 3DR today and according to the person I spoke with they are currently working a similar issue with another user. 3DR said there is a 90 day warranty on the APM and was going to RMA it but since I purchased it through UAV-America I have to return it to them for replacement. I contact UAV-America and Jim will send me a new APM as soon as he receives the old one.

    In the meantime I had ordered another APM for my hex copter. It arrived today so I will install it this evening and see how that goes. Stay tuned!

  • I am having the same problem.

    After many hours of troubleshooting this, I discovered that if I install FW version 2.6 I can get Mission Planner to work. Though I now have an issue with the altitude on the HUD display. It read -21438760 meters. Still haven't figured this one out.

    I've contacted 3DR but they have not responded yet. I'm beginning to believe that there is a problem with the APM2.5.

    I am curious to know if you install FW 2.6 if it work for you.

    Steve

    Steve

This reply was deleted.

Activity

Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25
More…