Motors not arming

I have the arducopter kit with all the stock equipment.

 

I just finished configuring the RX/TX in the conifgurator and everything worked perfectly.

I know I have RX power because I have a red light on but I cannot arm the motors at all. 

 

I unplugged the copter from the usb and put a LiPo on.  The boards boot and the Green light is solid.  I get no RX TX light, but when I turn on the TX the PPM LED blinks fast, when the TX is turned off the PPM light blinks slow.  I also hear a series of beeps when I power up the copter.

 

Any suggestions of things to try?

 

Could it be that I have not calibrated the ESC's?

I havent figured out exactly how to calibrate them.  I am unsure what the wiki means by plugging in each esc to the throttle channel of the RX.


Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am going to replace the board as soon as money permits.  Will probablly be around the end of Jan.  Thanks for all the help guys.  I am pretty sure that when connecting the lipos when I was done calibrating the ESCs that I fried the board/s. I had to modify the connections on the turnigy lipo's that I am using, and the connections that I bought at the local hobby store were not the best in the world.  They sparked mightly when I connected the battery, and I guess it may have arched to the board and hit it. 

     

    At least that is my novice idea.  I have tried just about everything I can think of to get the code to load, and the board to boot properly.  I am still stuck with the boards completely removed from the copter and the loading showing as successful. With nothing connected and the board powered by USB, I still just get the fast blinking and no solid lights at the end of the boot.

     

    I already have an extra spark fun board so I should just need the the green board.  I appriciate all the input!  Hopefully the new boards will do the trick and get me flying.

  • Developer

    Motors are armed to bottom right, if you arm them in B-L it means that your YAW channel is reversed

  • I checked all my solder joints and also tried to reload the code from home.  The APM will still not boot properly.  When I load the code, everything goes well, and it tells me "Upload Done" at the end.  Then the board tries to boot.  The three LED's flash really fast and then the TX and RX lights blink a little.  The three lights will flash a few more time really quickly and then nothing.  I can't get a solid green light anymore =(

     

    Is it possible the boards are fried?

  • John,

     

    first of all, which code are you using, RC_1 or NG ?

     

    Ric

  • My throttle stick is moving my Yaw and Roll.    I boght a turnigy 9x mode one and switched it to mode 2.  I set the controller for "stick"(mode) 2.  now things are backwards on all 4 modes or sticks when I pick them.  Any one have this problem with a turnigy TX?

  • John:

     

    Have you move the throttle to the lower right corner to arm the motors?  The A led should behave as follows;

    After initial and successful boot this LED will be on, and it is safe to move your quad.

    • Solid green: system ready and motors are disarmed, safe to move quad
    • Blink slow: motors armed, Stable flight mode
    • Blink rapid: motors armed, Acro flight mode

    Also is your altitude hold off?  I am not sure but I think that the throttle is disabled when the AH is on.

    I would highly recommend that you calibrate your ESC's before you attempt to fly.  This explains the how to:

    Turn your transmitter on and move the throttle to high/maximum.  Power your receiver with either a power source or a receiver battery of the proper voltage.  Plug the three lead bec/esc connector into the throttle channel of your receiver and then connect your lipo to the esc.  You will here a series of chirps from the motor.  Once you hear the chirps stop, move the throttle to low/minimum.  You will hear another series of beeps.  Disconnect the lipo and repeat for each motor individually.  If the beeps do not stop, then go back and start over by reconnecting the lipo with the throttle on max.  Once you have completed the motors individually, you can reconnect all of them to the power distribution board and you are done.     

This reply was deleted.

Activity

DIY Robocars via Twitter
16 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…