Tried the latest (1.2.25) Mission Planner on XP 32 -bit, made sure the atmega2560.inf driver was installed (Device Manager says it is there), fired up MP and tried to connect. It shows "(COM5) Atmega2560" in the MP connect area - had the baud rate at115200 (or whatever is normal) - but it says Connect Failed - Com5 doesn't exist. Tried rebooting XP, unplugging the APM2.5 (works just fine on Windows 7).

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Criterion-Industries,

         Thanks much for your expertise!

     

    Dave

  • Dave,

    Have you solved your problem?  If not, here are the steps that saved my sanity:

    You need to re-set your com ports through the device manager.  Open the manager, click view, click show hidden devices.  This allows you to see all the com ports that have ever been created on your computer (under COM&LPT).  Then, uninstall all of them.  My issue was that I could not uninstall the port assigned to the 2560.  This required a reboot of my computer with the ardupilot unplugged.  Once the port shows up as grey (not bold) you can uninstall it.

    For me, I uninstalled mission planner as well.  Once MP was gone, I plugged in the APM 2.5 and let windows install it on its own.  It re-assigned it to a new com port (3 in my case).  Then I installed MP (version 1.2.26) and it is now working.  I had another issue as well separate from the com ports which required another solution.

    Hope this helps,

    Criterion-Industries

  • Bueller?  Anyone?

  • Im having this problem with Vista.  My setup was very solid until I updated to 1.2.25, now I cannot connect in any way (USB or 3DR Telem).  Resolution to this issue would be great.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…