after update to l2.5.4 code on my apm1280 with disabled cli logging and gps set to MTK16 (not AUTO) the gps stopped working. status led on gps is on, but the gcs says "no gps" and loiter is not working. after compiling with auto, everything is ok. if i run gps test (auto), it says GPS MTK16 ok and then "no fix" without change, even tough the gps led is on (no blinking). any toughts?

Views: 508

Reply to This

Replies to This Discussion

I am having the same problem!

So I did some tests. Tried all of the recommendations. I then powered the APM with a 5 volt rc rx battery out of the copter to see that the APM planner has a 3D fix. Go figure after two days spent on this what was actually fixed?

It's a known problem that MTK16 gps does not work if you specify it in apm_config.h.  It only works when you let the software auto detect the gps.

If I add a small delay just before gps gets initialised, I could get the gps to work when on usb power, but never on normal lipo power.  I've been looking into it for a while, but couldn't solve it.

The blue led on the gps lights up when you have a 2D fix.  The red light on the apm only lights up if you have a 3D fix.

thats sad :( so much kb of precious memory wasted... anyway, thanks for the info.

Doesn't a reset help after waiting for a lock? That helps on my 1280 and I'm pretty sure I have set MTK16.

Also I have made the experience that the GPS is somewhat sensitive to noisy power supply (although other people may disagree). Since I power it separately I get a 3d lock (around 7 sat's) on my window board with no problems. Earlier it took quite much longer if it got one at all.

4kb wasted to be precise :)

Yes andre, it's possible that a reset while the gps stays powered helps, but I can't do that since my reset button isn't accessible in the hexa :(

Today I installed the APM back in the Copter to see if I still had the lock no 3D fix problem, and what do you think happened. One thing that I would like to note. When loading V2.5.4 Quad from the APM planner I had the GPS pluged in to the board. Today I reloaded V2.5.4 with out the GPS, Xbee and any RC gear. I then reassembled the copter and gave it a go. I had a 3D fix with 10 sat in about 2 minutes. Was that the fix to the problem??????

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service