I have the Spektrum DX7s with the AR8000 reciever and i am flying a 3DR APM 2.6 that has ArduCopter V3.1 installed. When i do a radio calibration the lower limit for channel 3 when i have the radio turned on is 1134. When i turn the radio off it drops to 1127. So what i would like to do is to set my FS_THR_VALUE to 1130 so that my copter will fly home if my radio dies. But when i set this value i get a never ending PreArm: Check FS_THR_VALUE error and my copter will never arm. In doing a little digging around (and looking at the source code) it appears that the upper range for this value is set to 1100.So of course my question is: what can i do about this? How can i get my copter to fly home if my transmitter dies?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • One small item to add to Gerard's excellent post. The Spektrum receivers set failsafe when the binding process occurs. That's how the AR8000 will see the new endpoint as the failsafe position. If you rebind at any time in the future, you will have to remember to set the lower endpoint to 125% (or lower) before you do so as not to mess up the failsafe. The FS_THR_VALUE really needs to be somewhere in the 975 (or below) range. My DX8 with an AR8000 gives a number of 930 with the throttle trim set all the way down and the lower endpoint value set to 140. That's where I bind and then return the lower endpoint value back to 100% and leave the throttle trim to it's lowest setting. When I turn off my transmitter Mission Planner reports the PWM as being 930 triggering a failsafe and in my case RTL.

    • Hey Guys, thanks a bunch for your input. The suggestion to do the 140 value worked great. Although mine was more like 145. and although i can't really tell the difference, i am happy to have more confidence.

  • All radios have settings like Trim or endpoint configuration buried in the menu. When your radio dies, it's the receiver that sends the failsafe values for all channels. 

    So what you do is configure the radio to have -125% on the lower endpoint and configure the AR8000 receiver with those new failsafe values. Then you set the radio back to -100%. Now you have a better difference between zero throttle and losing a radio signal. You only need to adjust for the right value through MP.

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…