Hi all,

i have big problem with navigation modes. Here is my setup:

APM 1280,

Oilpan v2,

Magnetometer hmc5883, AP_COMPASS_COMPONENTS_DOWN_PINS_FORWARD

GPS mtk16,

sw version 2.0.39b.

tricopter configured to X orientation

When i run test on compass and gps in terminal everything works OK.

In field after GPS lock, takeoff and short stabilized flight  away (100meters) i switched to RTL mode and nothing happens. Tricopter holds altitude but wind takes it slowly away. Not moving to home at all.

The same situation when i switch to AUTO mode with some waypoints loaded.

The log is for me puzzle, even if i have enabled all in log file. Most strange is that the CMD is in the file only once even if i switched modes several times. In the log file i can't find GPS records. Could it mean the ACM software is not communicating with GPS?

I attached also the log file if anybody interrested.

Views: 370

Attachments:

Reply to This

Replies to This Discussion

Now  I discovered why the navi modes were not working - GPS had lock(blue LED solid) but ACM hadn't (red LED on OILPAN was even not blinking).

I have to reset board after powering up the ACM then red LED on OILPAN starts blinking and when GPS blue LED became solid, red LED on OILPAN stays solid too.

Thought this error was long ago solved (note I have mtk GPS with latest firmware). Can somebody bring ray of light to this puzzle? Why I have to reset ACM after powering up to make communication between ACM and GPS possible?

 

Today I have tested RTL and AUTO modes on the field - working flawlessly. Only issue is - moving between waypoints and RTL is too slow ;o(. This is but question of PID params guess... Can't find some hint to tune up my tricopter (construction , motors and ESCs is the same like RCEXPLORERs)

That shouldn't be necessary. Maybe be a EEPROM corruption problem. Wait till we release 2.0.40 and do a CLI clear of your EEPROM and that should fix it.

As far as i remember i had the same issue with APM - every now and then APM could not communicate with GPS.

When i upgrade to newer version (APM or ACM) i always do clear EEPROM.

Now I found the problem - when I predefine GPS_PROTOCOL to GPS_PROTOCOL_MTK16 in APM_Config.h and use such modified ACM software, board has then problem to communicate with GPS after plain start. Only after reset it starts communicate with GPS.

When I leave GPS_PROTOCOL on GPS_PROTOCOL_AUTO then red led on oilpan starts blinking right after powering up and no more reset is required.

I used to predefine GPS_PROTOCOL to GPS_PROTOCOL_MTK16 to save some memory space when I optimized APM software since latest versions of APM exceeds memory room of 1280 APM  board.

With ACM software there is no problem with space room on 1280 board version so far so I can live with GPS_PROTOCOL_AUTO.

Now I don't know if the same problem appears on APM software 2.24 since for now I'm only interested in ACM and tricopter flying. 

Palo, I think ArduCopter 2.42 works on the 1280 board right out of the box. Jason has been doing a great job on shrinking the code size to keep the 1280 in the game, so try that one. 

 

Sooner or later you're going to have to upgrade if you want to stay with the state-of-the-art, but the team has managed to support the old 1280 much longer than I thought they could. 

 

As you've noted the old GPS defines aren't supported anymore, so please try to stay with the default code.

 

 

Yes ArduCopter 2.0.42 gets compiled fine for 1280 board without mods. The only modification I do need is for tricopters yaw control reversing as I described before in another thread and is made an issue for it.

 Yesterday I tried to get compiled also Ardupilot 2.24 on 1280 board. Unless I defined GPS_PROTOCOL_MTK16 it is no more compileable. With GPS_PROTOCOL_AUTO the code exceeds memory ;o(. Perhaps there will be the same communication problem with GPS after powering up the board.

Anyway to do additional reset is not big job and I can run 2.24 code on 1280 board ;o).

Sure I will upgrade to 2560 but this time is again in deeper future and I saved 64 bugs for it ;o)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service