New mission planner compass calibration

I have been unable to successfully perform a compass calibration since the latest update of mission planner. Each time I try, I get a message stating words to the effect "data not collected for all directions"When I attempt the calibration, I end up with a sphere of colored dots, an everything appears to be working normally. I have tried both the "compass dance" and Randy's technique but so far no success.Anyone else experiencing this?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Did you try CLI Test, Compass to make sure compass health is good?
    • Ok. I seem to think the problem may be at my end now. When I turn my compass through North, the heading indication seems to lag and pause around North. I really like the new presentation in Mission Planner.
      • Are you using external or onboard compass?

        I've had this problem on an external compass and found one pin/connector to be loose.

        • Hi Steven,
          Yes, this is my first quad using an external baro/compass. Gps appears to be fine, hdop around 1.8 using 8 or 9 satellites.
          Today, I'm going to enable the internal compass again and retest.

          Oh also, my compassmot figure was 24%.

          Thanks Alfie
          • Ok. Re-bridged the compass trace and the compass calibration worked perfectly. (Really like the new format) it seems I have an issue with my remote compass. More tinkering required!
            Thanks all.
        • Hi all,

          I had a pretty expensive crash today. The reason I suspected first was the wind and a low level flight in a guided mode just 2-3 meters above the roofs and houses witch may cause a GPS glitch (signal bouces against the oblique surface of the steel or ceramics roofs?). After few minutes of guided flight which was quite ok my quad suddenly lost orientation and start 'sniffing' far left, forward, backward rapidly... just an inches over the top of the roofs. One of them was a bit higher then the others... I panic and switched to RTL too late. Bang! (ling to youtube soon)

          - but... also a few days ago and today mornign as weel I was prompted by a MP for downloading a new version of the soft. I answered NO thinking I have NOT installed any new MP version. Reading about the necessity of recalibrating compass in this topic now. Am I right thinking that today mornig I really have NOT installed a new version of MP clicking 'NO' at the prompt? (I have 1.2.94 on the invitation screen, but from the other hand I wasn't prompted about the update any more)?

          I am afraid if some updates has been done automatically from the github and I forgot (didn't know about recalibrating compass... 

          Apart of this - I woluld like to ask If somebody can help how to download a logs from phisically broken APM 2,5 please? An A, B, C diodes are dead after connecting usb cable; but RX and TX diodes are blinking. Also the "alive" diode at GPS connection is on.



          • 3D Robotics

            That's a pretty old version of Mission Planner. The current version is 1.3. 

            • Question: Where on the web are we able to see what the latest version is?

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21