No data displayed, just 0's

Hi!

I can't get the OSD to show any values. They are all zeroes. Iv'e done a lot of googling but havent found the key yet.

MinimOSD v 1.1 with firmware 2.0. Updated charset. Bought a cable on Ebay to use telemetry at the same time.

APM 2.6 with Arducopter 3.1.

I switch it on, it says "Waiting for mavlink". I connect the telemetry. The previous text will go away and everything seems fine, all the text is there, but it is all zero/null values. The Heartbeat icon is flashing.

I read about the Arducopter not sending values by default, that you have to set the SR3-parameters. But like someone said, that are not there!

Also, going in to MissionPlanner / setup / Optional Hardware / OSD and clicking there, does nothing.

I tried using another MinimOSD that i took off of my Octocopter, that one shows the exakt same. But on the octo, it works with another APM 2.5.

I get the feeling that the APM is not sending out the data that the Minim needs to hear?

Please help, my hair is getting grey over this one...

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Rolf, 

    thanks, you were right, it was the cable! Your suggestion to hook up only the radio got me thinking.

    I exchanged TX and RX pins on the APM end with each other, and then also exchanged them on the Radio end.

    After that, 100% difference. Both APM and telemetry works now.

    Mind you, this was a cable i bought from Ebay, not one I built myself since I didn't want to fiddle with it. :)

    Thanks!

    /Magnus

  • check the TX connection from minimOSD, if this connection is missing you will only get the heartbeat message.

    minimOSD sends request for the data that shall be returned by APM.

    • Hi Rolf,

      thanks for the reply: My splitter cable indeed has only the RX connection to the MinimOSD. The Telemetry-unit has both RX and TX.

      Are you quite sure that both MinimOSD and Telmetry should have both RX and TX when used in parallell?

      As mentioned here: http://copter.ardupilot.com/wiki/common-minim-osd-using-with-a-grou...

      This is the cable I'm using: http://www.ebay.com/itm/251416147164?ssPageName=STRK:MEWNX:IT&_...

      Thanks again!

      /M, Sweden

      • Ok, if you have a radio telemetry connected then this should do the request to the APM (no TX from minimOSD) but  first after connecting to Missionplanner or some other groundstation software.

        • That's how I read it too. The connection to Mission Planner works well. 

          • is both LED's on the minimOSD on?

            • Yes. It reads the heartbeat when I connect to Mission Planner. It just doesn't read any values from it. 

              The display is fine, nice and sharp letters and the heartbeat symbol is blinking.

              • do you get the telemetry data in Missionplanner?

                • Seems I can't reply to the latest response, so I'm responding in the wrong order here..

                  I suspected the cable as well, and moved the RX wire to the TX position, but then I did not get any mavlink connection at all. When it is in the original position, as mentioned, I get a mavlink connection. Just no data.

                  • if you are using the 3DRobotics radio telemetry try connecting just the minimOSD directly using the cable used for the radio telemetry on the APM.  

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…