No good in loiter and RTL, just sometimes?


I have an APM2.5+ with the Mediatek 3329 V2.0.

My octocopter flies well in stab, but has very strange behavior in Loiter and RTL. At first I was sure it was just me not beeing able to dial in the PIDs, but me and an APM-using friend have spent weeks with it now. Two days ago, I got it Loitering pretty perfect by changing the Loiter-I to 0.1 (BIG octocopter) and Loiter-P to 2.

I was so happy! RTL also worked as expected. I even changed the values back to confirm that it again would start to misbehave, and it did! Overshooting, going back and forth etc, just way off target by 10-meters and generally acting confused. Then the batteries ran out.

The next day I set the values back to what had worked so well the day before.

But now, it was bad again. Acting differently though. I took it up to about 10 meters, about 20 meters away from me. Looking at Mission planner and the log, it shows that I had left the park area (green) and flown all the way to the housing area, over 100 meters away. Still, I had at least 9 satellites! This went on for minutes? Not just a glitch. 

Anyway, I'm thinging my Meditek is up to no good, and that might be why Loiter and RTL are so bad too.

In the pic below, not that I was never outside the inner half of the white cirle.

Logs attached.

Hoping someone can take a look at the logs and maybe find something wrong. I don't mind buying a better GPS if I know that it will help. 


Kind Regards,

Magnus, Sweden

2013-08-09 14-23-03.tlog

2013-08-09 14-23-03.rlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Update: I was at a friends house, and he loaned me his RCTimer GPS from the Arduflyer kit.

    We went out into the filed and took it up, it was pretty windy. Loiter was SPOT ON! 

    There is clearly something fishy going on here!

This reply was deleted.