Hi guys. My APM is not working and I wanted to ask you guys about it while waiting to hear back from 3DR support. I have an APM 2.0 with built-in GPS. It has flown 4 or 5 times with each each flight having greater success (ArduPlane firmware). The previous couple flights were almost perfect. However, last weekend I could not get a GPS lock. After waiting several minutes I tried pressing the reset button. Then after waiting about 20 minutes, I unplugged the UBEC power to reboot the APM. (UBEC with a separate battery is powering the APM and the BEC/ESC is powering the servos.) Upon turning the APM back on, nothing happened. No lights, nothing. I checked the connections and the UBEC and it was correct/working. At home I plugged the APM into the computer via USB, and the lights did come on (and Windows' Device Manager saw it), but failed to connect in Mission Planner. There was an error message, "No Heartbeat Packets Received".

I've set this unit up by the book and been very careful to have it correctly powered. Nothing unusual that I know of happened to cause this.

Is there anything I can check or do to fix this?

Thanks,
Parke

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am having the exact same problem with my APM 2.0 board.  A handful of successful flights.  Nothing out of the ordinary happened between the time the board last worked and the time that it stopped connecting to MP.  When connected via USB, LED indicators working as expected, board is detected and correctly shown in the Device Manager but I get "No Heartbeat Packets Received" message when trying to connect with MP.  I receive this message when trying to connect via USB or X-bee.  Attempted to reload firmware and get - "Cant detect your APM version" error.  Also tried to connect via CLI with no luck - I get "Opened com port" but no initialization message.  Rx LED blinks when sending commands but no response back.

    Any suggestions to help get flying again would be appreciated.

    Mark

  • Thanks Søren, I'll give this a try tonight. To answer your second question, no nothing was changed. It was working (except for the GPS locking in), I unplugged it, plugged it back in, and it was dead.

    -Parke

  • Hi,

    Check again that you have the right port selected in MP. Try open the port in a terminal emulator program, such ass HyperTerminal or TeraTerm, suing the correct speed 115200 bits/s. Do you see data?

    Did you change any of the solder jumpers on the APM board?

    And finally - does flashing new firmware work in AP? You should select the port but not connect before you do this.

    Regards

    Soren

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
6 hours ago
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Monday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Monday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Monday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…