MR60

Thought the problem was a potentially faulty APM 2.6 so unwrapped my PixHawk.  Same problem.

In MP, it connects and downloads the firmware.  Pixhawk then gives the successful happy song.  Select connect via Mavlink:

- starts 30 second countdown

- red connect changes to green disconnect

- timer goes to 0

- continues trying or doing something for another 1 1/2  minutes while countdown stays at 0

- then get No Heatbeat error.

In Windows 8, Device Manager, Com 5 is set to 115200, 8 bits, no parity, 1 stop bit, no flow control, FIFO buffers.

In MP, Com 5 PX4 FMU v1.6 (COM5) is selected.

Tried:

- restarting the computer

- connecting via a different computer (windows 7 and an older version of MP)

- four different USB cables plugging into different USB connections (getting desperate)

- different com settings

I'm beginning to think i'm in a no heatbeat black hole.  will see if i can setup the radio (but can i do that without mp?)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • That was my initial thought too and why I asked my friend to remove the cable from the Pixhawk, although there were no signs of issue wit the cable. In my head I was thinking something had shorted/tricked the mavlink into bootloader mode.

        Whatever it was, I was just very pleased to be able to get the issue resolved without needing replacement parts and to get my friend flying his new toy.. and this thread was my only source of info for doing that.

  • Hello folks,

    Just as an update, I had this same problem on a friend's iris last week. I found this thread very helpful and I was able to resolve the issue without the need for a new GPS/Mag unit so I thought I'd share for anyone else who may experience this.

    No heartbeat, couldn't connect, tried alternative 433 Mavlinks, still no joy. GCS Mavlink flashing green, iris mavlink solid green flashing red.

    iris mavlink id 68 (on sticker - not connecting properly to Mission Planner...may have been my fault!)), GCS mavlink id 28 (on sticker). Confirmed GCS Mavlink id of 28, changed to 68...still no connection.

    Checked Mavlinks, found that the one attached to the iris was in a constant bootloader state (solid red led) when directly connected via micro usb to pc - tried to restore to default which partially worked but wouldn't confirm finished on the mavlink itself by changing from red to green LED.

    Removed GPS/Mag from Pixhawk to check if this made a difference, it did. iris mavlink after restore to default confirmed reset by changing to a green led. Net id25. Restored the GCS Mavlink to default, again net id25. Powered iris with a battery and connected to mission planner and confirmed mavlinks were working/talking...all OK.

    refitted GPS/Mag connection on Pixhawk. Powered iris with battery and connected with mission planner. All working.

    Seemed to do the trick and the iris has had a few flights, connected to mission planner with no probs...

    • did you check the USB port is work?

      My one is not work on USB, it works fine in radio.

    • I posted yesterday about this problem.  I am glad I found this thread.  I failed to mention in my problem that the Multi=color LED had never lit up but was hoping that happened after calibration... ANYWAY,

      I disconnected the GPS uBlox Mag and the UBec power cord to the PIXhawk and well I'll be !  Success!

      Looks like the GPS prevents connection with MAvlink at this stage of the set-up.  I have not done any calibrations yet.

      On to the next problem... heheh loving it though.

    • 3D Robotics
      Interesting. That's a new one for me. Any idea what the connection between GPS/mag and radio might be? They use different serial ports.
      • MR60

        This happened again on another new Pixhawk. Agree with Leon, that my earlier problem wasn't a faulty GPS/MAG (I'll explain why later).  This is what just happened and how I think I fixed it.

        After downloading the firmware ...

        With GPS/Mag connected to Pixhawk.  CONNECT ... no heat beats

        Pulled both connections to the GPS/MAG.

        Then pressed CONNECT ... it connected; disconnected; Tried again.  it connected.

        Attached 5pin to GPS/MAG.  it connected

        Attached 4pin to GPS/MAG.  no heat beats

        repeated the sequence and confirmed again that the 4-pin on the GPS/MAG was causing the issue again.

        So with only the 5-pin connected to the GPS/MAG connected, told Mandatory Hardware that I was using a Pixhawk GPS/MAG.

        Attached the 4pin.  it connected!!!

        Then attached the 3DR OSD.  no heat beats.

        Disconnected the OSD.  it then connected

        repeated sequence to verify OSD issue. verified

        With OSD disconnected, connected via Mavlink.

        Plugged in the OSD while connected

        Went into config to update the OSD

        then disconnected Mavlink

        then pressed CONNECT ... it connected!!!

        The reason why I know it's not the GPS unit that I thought was faulty is because I swapped it out after this was all working and sure enough, Mavlink connected.

  • I believe mission planner needs to be set at 57600 on the port. Try this out because thats how i have mine connected.

    • 3D Robotics

      57600 is just for the radio connection. A direct USB connection should 115200. 

      Forrest, the baud setting in the Windows Device Manager doesn't matter. What matters it the baud rate in MP. Are you sure that's set to 115200?

      • MR60

        Hey Chris -

        Turned out my problem was a bad mag in the GPS/Mag unit.  It would connect until the mag wire was connected to the Pixhawk.  Had a spare GPS/Mag, which worked fine.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…