Hi. After weeks of fighting this I'm getting pretty close to giving up on ever getting Er9x firmware installed on my 9x transmitter, using a SmartieParts SP Basic programmer board.

The 9x is new and of recent vintage with the programming pads in the required places for the SP board. I've now been through two of these boards (they're both of the current type where you have to use a washer on the left mounting screw to hold the board down, due to a manufacturing defect).

As far as I can tell the pogo pins are aligned on the pads as well as is possible, and I have tried cleaning off the pads.

I'm testing with the 9x powered up and with plenty of juice.

No matter what I do, I get the notorious avrdude:

Avrdude.exe:error:programm enable:target doesn't answer.1

avrdude.exe:initialization failed, rc=-1

error message when I try to read from the 9x (memory read, firmware read, etc.)

This occurs along with a beep from the 9x as it appears to reboot.

Tests with the "Companion" software yield the same.

I have not done anything that should have changed the fuse states, in fact I have not tried to write at all to the unit, only reads.

Steven at SP has been very helpful but says he's at a loss as to where to look.

I did try one read op with -F to see what would come back, and got:

avrdude: error: programm enable: target doesn't answer. 1

avrdude: initialization failed, rc=-1

avrdude: AVR device initialized and ready to accept instructions

avrdude: Device signature = 0xc8875f

avrdude: Expected signature for ATmega64 is 1E 96 02


which Steven says he does not recognize. For all I know it's just garbage data. At this stage I'm not even certain that all pins of the SP unit are properly contacting, but I've done what I could to try assure this.

I've also already tried using the -B delay flag, up to at least -B 1000. Same error.

Any suggestions would be greatly appreciated! Thank you, and best for the New Year!

L

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

This reply was deleted.

Activity

DIY Robocars via Twitter
Jan 28
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Jan 23
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Jan 23
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Jan 23
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Jan 22
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Jan 21
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
More…