No RTL after Radio Failsafe (log included)

I had a very disturbing experience a few days ago. One a very routine testflight the X8 conf copter went suddenly in radio failsafe (~289m from pilot) and instead of RTL it started to just...fly around. I have tried both Loiter and RTL number of times before this flight and they both were working. The main question is why it did not RTL?

Some additional info:

*Arducopter 3.2

*X8 conf copter (~17kg)

*Spektrum DX9 + AR10000 (main receiver antenna + 3 satellites) with PPM encoder

*I have been testing different copters in the same spot for over a year, no problems with the spot.

*I have flown over 500m LOS with the same copter and it never lost connection between RX/TX.

About the flight:

I did a forward straight line, stopped and started to come back but on the way back the copter made a sudden movement and started to just fly around. I tried switching between different modes and it seemed that I occasionally had control over the copter (10% of the time). I started running to the copter and tried to pilot it in the same time. After about 3 minutes I somehow had enough control to land it unharmed. 

Could someone shed some light on what might have gone wrong?

2015-04-25 13-51-48.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

                  • Good day, Hugues. If You replied to RdanielK, then I would like to point out, that he set RX failsafe values to 50% (Roll, Ele, Yaw and Throttle) + CH5 value to RTL. I may be wrong here but You do not have to have Throttle failsafe activated in that situation since the Throttle value is set to 50% in failsafe situation and the copter should change mode to RTL because of the CH5 failsafe set value. Or?

This reply was deleted.

Activity

Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25
More…