APM Mission Planner HUD attitude indicator is working great but there is no telemetry ie Altitude, ground speed, heading and etc on the HUD display.   I'm running Ardupilot APM 2.5 and Mission Planner 1.2.36 on a Dell Windows Vista Optiplex 330 that runs CAD fine. Newbe here that needs some advice.Thanks in advance.

In the Mission Planner's Status tab I see that all the telemetry is working but not displaying on the HUD. What am I not doing correctly?  I've got everything else working including GPS, 3DR Radio and Spektrum Receiver.  I tried powering the APM via the USB then battery only but still no telemetry. 

Views: 706

Reply to This

Replies to This Discussion

Problem solved.  There is not a switch in APM Mission Planner to turn of/on the HUD telemetry!  The problem was that my ATI Radeon HD 2400 Pro could not handle the telemetry with driver 8.420.0.0.  Once I updated to 8.920.0.0 voila the telemetry appeared.  Lesson here is to run the latest video drivers.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service