Hello,

I am beginner in flying a RC-Heli. Ok I try to learn it for 3 years, but I have to little time. I can float with the heli and I flown some hours with a simulator. But I am a technic freak. So what's next? I want to install an ArduFlyer 2.5 into my Skya 450 V2 to get a better chance to learn flying my heli. I know that many of you think it is not possible to get this working without knowing the basics how to fly a heli. But I'll try anyway.

I am starting this thread here because I want to show you what I am doing and of course I want to ask questions ;-)

Here is a short video what is showing what I have done today to start my project. My other project to build a tricopter with an Ardurino mega with my own software on the Ardurino is still going on too. But I finally want to fly my heli in the next summer....

https://www.youtube.com/watch?v=1MoFXiUq-ZE

Next step is to set up the heli for flying manually. I changed all servos to digital ones and I bought a new ESC with governor mode. So I have to get the heli flying again before I tried to install the ArduFlyer.

to be continued...

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am so sorry for my problems R_Lefebvre, but this doesn't work. It seems that nobody have such stupid problems with that. I tried to search infos everywhere, but there is nothing which can tell me what I am doing wrong.

    Here is my current setup (see picture below). Maybe there is a mistake here?

    I tried all directions to hold 5s while booting. If I hold the collective stick down and to the right (rudder), the APM is not moving the servos and the LEDs are in rotating flashing (all three LEDs). If I move the collective stick up and right or left, the APM LEDs flashing fast and then the red and the blue LED flashing slowly. But then nothing changes to solid LED. The swash plate is while booting a short period in middle position and the moves to high position. After that the servos are reacting if I move the sticks for ROL and NIK, but the plate is too high.

    Red = Throttle (collective stick) is in my TX = Pitch, move stick up = signal -100%, down = +100%

    Yellow = Rudder, move stick right = +100%, left = -100%

    Green = Nick, move stick up = +100%, down = -100%

    Blue = Rol, move stick right = +100%, down = -100%

    All the signal are working independently. No mix and other things.

    Here is a short video (<1min) to show the stick movement on the TX servomonitor and then the swash plate in manual mode:

    http://youtu.be/n7n6mNhDgoE

    3692722505?profile=original

  • Hi R_Lefebvre,

    thank you very much. That is exactly the info I need to get some light in my head. Ok, I will do so.

    Servos: I have the APM power module and actually I connected the servos to the outputs of the APM including the power pins. I guess that is not right. I read that is also not the best to power the servos over a separate 2S Lipo / BEC. But there I have to search for a better solution. Is it a possibility to get a second APM power module to power the servos, but max. 2.2 Amp it not enough?

  • No the first testing of the board is done. In the flight data mode from the mission planer I can see that the sensors are working. The gps gives me the position too.

  • So, now I have the first issue. I loaded the 2.9.1 with the Mission Planer 1.2.34 mav 1.0 on the APM. Upload is complete but the verify ends with an error:

    "Upload succeeded, but verify failed: exp 77 got DD at 90"

    Is this a problem of the board?

    Regards,

    Gerd

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…