We have here a Hotel 1.0 oilpan 8/19/2010, on a 2560 APMega.    :>( 

It has worked fine for a few flights on a plane, and have been setting up now in a 450 heli.  It seemed to be working correctly until tonight... 

Have done only a few run ups on the ground, getting gains adjusted to get good yaw tail hold.  Got the tail holding good, started to lift a little more and then it almost flipped over!  Now on startup, the attitude display starts level and then flips over to one side, showing approx 90 deg roll.  It's like it had a few beers and fell off it's stool.....   Then I noticed that stabilization swashplate travel was no longer working for roll axis at all, and pitch axis was reduced.

It seems to do same behavior either in heli over telemetry, or with APM/Oilpan removed and plugged direct to usb.

The Z axis is maybe normal.  but the X and Y are not making sense to me?   The APM was rotated back and forth 180deg through pitch and roll axes.    The X changes only 1-2 counts, and the Y changes a little more, but I think not enough.

Does this look like a solder joint issue maybe I'll look close for it and maybe fix?  Is this just what it looks like when the AD335 has retired?  Might I send this for repair?    Vibration induced failure?

Views: 192

Reply to This

Replies to This Discussion

Touched up the solder on the x y and neighboring pins.  now the y axis works normal again.   But the x axis output seems shorted to ground.  At the pins on the ADC, the y and z are 1.6 +- now, but the x is 0.

It was able to be fixed!    Instead of a new oil-pan, I ordered a hot air rework / solder station, only about $90, and it works nice.  Way good for shrink tubing, and the solder iron heats up very fast.  (I did open it up and double check inspect it, but all looked good enough.)  http://www.amazon.com/852D-Soldering-Rework-Station-Nozzle/dp/B009P...

 Used the hot air rework blowing on the top, and preheated the board from underneath with a regular heat gun,  with tin foil masking other nearby components on the top.  Also used soldering iron and ball of fresh solder and ran around edge of the accelerometer chip.   Not sure which worked, but it was one or both....

I had worked on it over Christmas break.  After the soldering work, the raw ax, ay, az values were working correctly again,  each going from approx + or - 1000.   But somehow it was not initializing correctly, and the attitude was going to a high pitch up attitude right after turning on.   I'm not sure why or how that was happening.

I finally got around to checking it again now.  Now the initialization works correctly.  No change to the s/w, still Arducopter 2.9-rc2 is loaded in it.  But now the attitude works correctly.   I'm not familiar with how the initialization and zeroing currently works, but seems that leaving it alone for about a month made a difference.   ?? Any ideas why this might happen?

oh well, I take problems that mysteriously disappear.  Back into the 450 it goes!

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service