**PANIC** radio_initialise failed



I just got my 3DR 433 mhz kit. But one of the radios seems to have a problem.


When i plug it into my computer using tha FTDI cable the green light stays on and the red one blinks once about every scond. The terminal says:


radio_initialise failed"


The hardware seems ok. I was able to get it into bootloader mode by shorting the CTS and ground. firmware was then updated sucessfully. My other "Air"-radio is fine and i can upgrade firmware in "AT" mode and configure it with APM planner. 

Im running:

Windows 7

APM planner 1.1.81 mav 0.9

Any suggestions?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • We recently experience this problem with a 3DR v2 radio. Re-installing the firmware did not fix the issue. In a last ditch effort, we removed the heat shrink wrapper from the radio, baked the radio in the oven at 375 F for 10 minutes, and then let it cool normally for 30 minutes. After this, it worked great. Our guess is there was poor/broken solder connection and our ad-hoc solder reflow fixed it.


  • Developer


    Does it continuously print that panic message, or just once?

    If it happens just once then it isn't really an issue - as soon as it prints that message it reboots, and if it doesn't panic again it is fine. If it happens continuously then the radio is broken.

    Cheers, Tridge

  • Hi, I'm getting exactly the same symptoms as the original poster on both (ground and air) of my radios.

    These are the set I bought: http://www.goodluckbuy.com/index.php?target=products&product_id...

    When powered the green LED is solid and the red LED flashes briefly (about 1hz)

    Ground PCB says 3DR Radio USB v1.0

    Air PCB says 3DR Radio v1.2

    I've tried reflashing the firmware (which succeeds) by shorting the 3rd pin with ground to get the solid but neither respond to any commands and constantly print

    **PANIC** radio_initialise failed on the terminal screen (correct COM port and 57600 baud selected) and doesn't respond to any of the AT* commands.

    I've tried both the radio part of the latest Mission Planner and the 3DR radio tool.

    I have contacted Goodluckbuy to request return (not that I hold out much hope)

    I'm out of ideas, is there anything I can check hardware wise for continuity / incorrect wiring?


  • I can not get my 433 3DR radios to connect and I have tried everything I dont understand why the device ID is RFD900 when it is a 433 radio. I cannot fill in the Format box either by copying or manually and the second version box will not complete. Anybody got any suggestions



  • I seem to be having the same exact issue as you. Did you ever get it fixed or just a replacement?

  • Developer

    Hi kbcopter,

    I've had this happen to me twice with these radio during the development process. The two causes were:

    • a bad ground connection (I was grounding the wrong pin due to a bad cable!). It worked fine when I fixed the cable
    • a wet radio after I 'landed' my quadcopter in a shrub after it had been raining. It worked again once I let the radio dry out

    In both cases the radios would panic continuously on boot. After I fixed the causes they were fine.

    The 'panic' messages happen because the 8051 doesn't get sensible replies from the radio module when it tries to initialise the radio. That does sometimes happen on a software reboot using ATZ if we've left the radio module in a bad state (ie. I probably don't have the reset code quite right), but it shouldn't happen on an initial powerup. If it does happen on initial powerup (which it seems to be for you) then its almost certainly a hardware issue.

    As Sam says, you can send yours back in for replacement, but if you prefer to tinker a bit first, perhaps the above will help you work out what's wrong.

    Cheers, Tridge

  • Is there a general way to unbrick these radios?

This reply was deleted.