I am not sure if this is the right forum to post this...if not, please advise and I'll move it.  I am an Iris owner...original Iris, not Iris+.  However, I am updating my Iris to the + with the upgrade kit.  In advance of actually installing the kit, I was playing around with the Iris+ parameters.  Iris+ has redirected flight modes from the original Iris.  When selecting the Iris+ parameters, the flight modes are modified to match those of the Iris+, which is what I would expect.  

However, then I decided to put my copter back to the original Iris parameters.  In doing so, the flight modes did not change back to those of the original Iris, but remained as they were for the Iris+...is this the way it should work?  Doesn't seem right, but not sure if this is a glitch, bad code, intended, or what.  I can manually put these back, so that part is really not that big a deal, but I have to wonder, if the flight modes do not follow the assigned parameter template, what other parameters remained in the Iris+ model versus the original Iris template.  Since I didn't think it necessary to save my original Iris parameters, I don't have those to compare to.  Anyway, in that I will have installed the Iris+ upgrade kit before the end of tomorrow, not a huge problem, but if this is a glitch, I thought I'd bring it out for comment.

TIA

Views: 172

Reply to This

Replies to This Discussion

The parameter files are intended to be applied against the defaults to configure a vehicle, not to swap between vehicle configurations.  We do it that way because it uses less memory.  The flight modes will change when you load a new parameter file.  If they did not then something else happened.  Perhaps you forgot to save the parameters to the vehicle.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service