I am trying to do PID tuning using channel 6 and everything seems to be going ok, except when I reconnect to MP, the settings I am not tuning go back to default. For example, if I am tuning P with channel 6 and I save I as 0, when I reconnect after tuning, I is at .10. When I initially write and refresh the values, they appear to be saved correctly, but once I disconnect and reconnect to MP they get reset. 

Any help is appreciated.

Views: 530

Reply to This

Replies to This Discussion

So, it looks like others have seen the same issue:

http://www.rcgroups.com/forums/showthread.php?t=1820773&page=13...

Has anyone here had problems with PID values getting reset or changing?

Not sure, but possibly.

I was tuning the loiter gains. Got the copter flying well, landed, connected to mission planner, and went to the config page. It loaded and merrily showing a nice sensible P value, so saved the values, changed to CH6 none, saved this, then went to fly, and loiter was non exitent. Landed, connected to mission planner again, and the  P value had cleared. Typed it in manually, and saved, and it then worked fine.

There are a couple of other 'sillies' with it. Some of the values don't allow you to put the 'legal' range in on the CH6 range. So you have a value where the recommended range is (say) 0.2 to 0.6, and try to put these as the endpoints for CH6, and it won't accept them.

It does seem sometimes to reject the pot values. Intermittently though. Have done the same sequence on some other values, and it accepts them fine....

Best Wishes

Maybe I am doing something wrong, but none of the guides I have found show step by step what happens when you set pids and channel 6 values, write them, disconnect, arm, fly, disarm, and reconnect to MP. My experience so far is that values change randomly and it is hard to know what values I am actually flying with or how to save them permanently. Very frustrating.

The way I've understood you should do it is:

Setup and adjust.

Land. Don't adjust your pot.

Leave transmitter running.

Connect.

The value you now see in the adjustable field will be what your pot is now returning. Save this.Turn off the pot control.

For me this works 99% of the time. Just occasionally it can seem to fail to save, but very rarely.

Best Wishes

Thanks! I think I ended up with some good values, but then random changes didn't make me very confident.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service