Good afternoon,

This morning and afternoon my flying group and I were flying a Multiplex EasyStar fitted with a Pixhawk complete with all necessary sensors. All the radio and sensor calibrations had been finished successfully, and we launched it with me at the controls and Qgroundcontrol 2.5.0 as the ground station. The plane flew well in manual mode, but when I switched to auto-loiter mode, the plane turned belly up and seemed to fly upside down for a moment before I hastily regained control in manual mode. One person suggested calibrating the gyro upside down, just in case there was a mismatch between the calibration instructions and the true calibration protocol--which had been the case for the compass calibration. We did so, but the plane inverted again immediately upon switching to auto-loiter.

We have had a successful loiter with Qgroundcontrol and a different Pixhawk. This is a recent development.

What suggestions do you have regarding getting to the bottom of this?

Kind Regards,
Jake Green

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,

    Did you find a solution regarding the reverse issue on stabilized mode ?


  • Hello Jack,

    I am new in modelism and I have never worked with it before.

    I found your topic and I have some problems arming my Multiplex Easy Star with a pix-hawk. So I hoped you would be able to help me.

    I worked with QGroundControl and I reached to make all set up to all sensors (except the airspeed sensor because I don't bought the right one) to all flight mode. All in the summary is green except the sensors. But when I try to arm it my pixhawk still blinks red and make these noise (dah-dah-dah-doh) so as to tell me that there is a GPS problem. So I can't arm my multiplex.

    Can it be the lack of airspeed sensor which stop arming system ? But I would not understand why if it is so.

  • Here is an update on our situation: the problem is within the "Stabilize" mode. This was seen in "Auto-Loiter" because it auto stabilizes here too. Instead of countering whatever roll bias the plane has in flight, the ailerons turn into the roll more and more as the angular offset changes. It is certainly a servo reversal that is needed. However, it seems as if only the radio controls can be reversed. I suspect that the auto controls bypass the RC and have nothing to do with our RC settings. Can anyone tell me whether there is a parameter in Qgroundcontrol that can reverse the servo output in "Stabilize" mode?

  • 3D Robotics

    That just means that you need to reverse the direction of the servo output. It's just a checkbox in Mission Planner and APM Planner -- I'm not sure about QGroundControl. You should always check control surface direction on the ground in an auto mode (stabalize, FBW, RTL, etc) before launching

    • Thanks for your reply, Chris. Which servos need their output reversed? We have had issues in the past with servo output needing reversal, but as far as I could tell all servos were operating correctly. The plane flew well in manual mode. In MP or APM Planner is there a checkbox for servo reversal isolated to a particular mode like loiter?

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25