Hi!

I have started my first custom drone setup and stuck on ESCs calibration.
I am using Pixhawk 2.4.8, my RCS is RadioLink AT9S, R9DS receiver is connected to flight controller via SBus, ESCs are Turnigy MultiStar 30A BLHeli-S Rev16 V3. I upgraded Pixhawk's firmware with QGroundControl, then I binded AT9S, calibrated Pixhawk's sensors (accels, gyros, etc.) and radio in QGroundControl.
I tried to calibrate ESCs according to official guide. I turned on my transmitter and put the throttle stick to maximum. I connected my 4S LiPo battery and heared three beeps (apparently from motors), then sound from buzzer "Start up OK" (ardupilot.org/copter/docs/common-sounds-pixhawkpx4.html), then two beeps with rising tone (from motor). Pixhawk's LED became flashing blue (instead of red, green, blue flashing). So board didn't switched into calibration mode. In tutorial (http://ardupilot.org/copter/docs/esc-calibration.html) it is noted that some brands of ESC do not allow calibration and will not arm unless you adjust your radio’s throttle end-points so that the minimum throttle is around 1000 PWM and maximum is around 2000. In QGroundControll PWM_MIN is set to 1075, PWM_MAX - to 1950. I changed these values to 800 and 1600. I changed in transmitter's settings throttle endpoints to 140% (with old values PWM_MIN 1075 and PWM_MAX 1950). After every modification I provided recalibration of the radio, but nothing changed.
What could I miss? What could be the problem? Could I skip some sufficient step during the constructing process?

Views: 209

Reply to This

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service