Pixhawk GPS horizon error

I 'm hoping someone can help!

I have a pixhawk with latest version firmware and i cannot get it to arm in loiter due to compass variance and GPS Horizon error.

I have done a complete re-calibration with no change, I have disabled the 2nd compass in mission planner with no change.

Im stuffed as to what's going on everything is mounted with correct orientation. 

Sometimes it works, but most of the time it doesn't. When it does it flies perfectly stable in loiter and holds it position  even with relatively high cross winds. I've seen it pitched at about 5 degrees to keep its location.

All I have done since the last good flight is add a couple of LED lights to help with seeing the orientation of the craft at distance, added a cable from the RSSI output on the frsky receiver to the SB port on the pixhawk and changing from dipole antenna to circular polarized on the FPV.

Any help would be very much appreciated. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thank you very much Alex, I'll do that and test it again.

  • Hi Joan,

    I would NOT suggest to switch off the Geofence Failsafe. It's a nice protection for fly aways.

    I finally solved this issue by fully switching off the internal compass function. After some time (a few mins)  outside, the Pixhawk will notify by a sound  that the copter is Armable .

    Alex

  • Hi all

    I had the same problem, and I did the same than Vipe. I've disable the Geofence and I could arm the Pixhawk.  But if I enable it, the problem appears again.

    So I'll let the Geofence disable for ever, unless somebody finds any other solution.  I have a neo-8m too. 

  • Hi all!

    Has anyone solved this problem yet?

    I' ve the same issues as described here. When i observe the gps groundspeed i find my copter just moving a little. I mean to say that my copter seems to move in a fixed stable situation with hdop = 1 and nsats ≥10.

    Thank you so much for any reply,

    Alex



    Michel Stathakis Neto said:

    My GPS module now is ublox neo-8m but it also happened with the previous one the ublox neo-6m (reason why I changed it to 8m hoping fix the issue). Other curious thing is that when these difficulties arises the GPS location really appears to be weak in terms of ground speed and position variance, despite 3d fix status and good HDOP less than 2. Again with Ublox neo-8m aways same problem, same fix, have to set parameters to default and config it again that works perfectly with the new set 5 minutes latter in the exact same position.
    Other thing I heard is related to the auto config done by pixhawk to GPS module during start up, there they said that is recommendable to make config the GPS through its own config software and after that not connect the GPS rx pin to pixhawk tx pin in order to not allow pixhawk to miss config the module. I didn't tried this yet, some one heard this or tried this ?

  • John,

    I have the same problem periodically.  From my reading I believe the root of the problem to be the GPS not getting a good, stable satellite lock.  If I move the copter to a more open area, or sometimes just wait it out (the satellites are not in geosynchronous orbit) it will finally settle down and the errors ( Horiz and Speed errors mostly) will go away and the copter will arm.  On most days, I am lucky to get 7 or 8 satellites initially.  The Hdop is up around 2.0.  When I finally get 10 or 11 satellites, the Hdop drops to 1 or below, the errors go away and the copter arms. 

    I am running a Pixhawk knockoff and some knockoff NEO-M8N GPS.  I have a new UBlox M8N coming in a couple of days and I fully expect that to eliminate, or at least reduce the problem substantially.  I will report back with the results of that test. 

    What GPS module are you running?

      Doug

    • My GPS module now is ublox neo-8m but it also happened with the previous one the ublox neo-6m (reason why I changed it to 8m hoping fix the issue). Other curious thing is that when these difficulties arises the GPS location really appears to be weak in terms of ground speed and position variance, despite 3d fix status and good HDOP less than 2. Again with Ublox neo-8m aways same problem, same fix, have to set parameters to default and config it again that works perfectly with the new set 5 minutes latter in the exact same position.
      Other thing I heard is related to the auto config done by pixhawk to GPS module during start up, there they said that is recommendable to make config the GPS through its own config software and after that not connect the GPS rx pin to pixhawk tx pin in order to not allow pixhawk to miss config the module. I didn't tried this yet, some one heard this or tried this ?

  • Mine is doing the same bollocks. just updated firmware,was fine earlier, flew Saturday.

    Now it won't even arm.

    I suspect the firmware is at fault as it won't even arm and complains a bunch about gps stuff (number of sats,etc) even thought it is not supposed to check for anything and this is the exact same spot where it was first setup (her, I am assuming the GPS/Glonass system is still working as my phone is fine.

    • WOW, just WOW!

      Found what it was, pure luck too.

      Disable Geofence.

      It is as simple as that. It was never an issue before.

      Quite disturbing as all pre arm/arm checks were disabled. I'm going to get a beer now.

  • May I´m saying some bullshit, but to me it seems to be not real errors and are related to some kind of corrupt in internal parameter set. It often happen to me and nothing works to fix  it, unless restore all parameters set to default and make all calibration all of then again...(copter type, radio calibratios, acel, gyros, mag, control mode, limits...) A lot of hard work every time. Download of  a copy of parameter set known and saved before in a healthy condition also do not works.  Only full parameter reset works to me and it magically disapear for some time.

  • Same here! 

    just put together a new x8, loaded the latest FW and I get the same error.

    Has anyone found the solution?

     

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…