Pixhawk PreArm: RC Not Calibrated issue

HI all,

Today I swapped a Spektrum DSMX satellite RX for a Lemon RX 8-channel, with PPM output. I tested and calibrated before sticking down the hardware with foam tape. The new receiver bound and connected on the first try. All of the other hardware seemed happy as well. RC calibration worked perfectly. When testing afterward, I can't get past a RC not calibrated error. I've recalibrated several times. I put the old RX back in. Same result.

The funny thing is, the ESCs chirp as though I hadn't performed ESC calibration. I've repeated that too. They don't stop chirping when I hold the safety switch.

This copter flew this morning. I'm stumped. Any help would be appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I should clarify. I swapped in the Lemon RX and removed the Spektrum.

    I also tested the system without any Rx connected and got the same result. I would expect Mission Planner to give me a "No RC" failsafe error, rather than the "RC not calibrated". Still stumped.

This reply was deleted.