I bought Radiolink Pixhawk a few days ago. Loaded it with APM plane 3.9 and mounted it on my flying wing. Did all bench test like stabilizing, failsafe trigger and power module tuning. All worked well and i also did a test flying. During first flight it behaved normal, i tested stabilize mode and it was stabilizing the wings but with nose down posture so i thought i need to do acclerometer calibration again by keeping nose a bit up so that it can maintain level flight. I also connected mavlink to TBS diversity receiver and i was getting flight data from pixhawk to ground TBS crossfire tx module on Tower app on my android through bluetooth.

Now next day i did calibration and my buddy launched the craft just after takeoff motor shut down and i had no control from transmitter. I did another launch same thing happened again. As my buddy launch the wing within 1sec it cuts the throttle and the rc control. 

So i reinstalled the firmware and did all mandatory stuff. Then i tested it on bench. I found that after arming as i increase throttle more than 50% it cut the radio signals and after 3 sec it cuts the throttle. Pixhawk reboots  it self. At first i thought it can be a faulty power module. So i changed it with my old trusted one. Then tested in workshop( bench test) there it worked fine it was not cutting the signals and i had control over power.

Next day at flying field i took off and did some circuiting checked stabilize, it behaved weird so back to manual. After 1 min. for flying i suddenly lost the radio signal and craft crashed it the ground with resumed throttle. There is no problem with radio, it works very well because i've tested it over 15 miles.

i can't figure out what is wrong with it. 

Following stuff i used-

Radiolink pixhawk with M8N Gps

TBS Crossfire radio system with diversity receiver providing PPM out.

Turnigy 9xr Pro

Views: 65

Reply to This

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service