I'm trying to get SITL simulation working and I've managed to build and start everything, but after I set ArduPlane in auto mode the plane starts acting weird and doesn't flies to the WP correctly.

    I've recorded my attempt in the video below:

Am I doing something wrong?

Best regards,

Leonardo Bueno

Views: 699

Reply to This

Replies to This Discussion

Rephrasing my questions to make them easier to answer...

1) When doing a SITL simulation, do I need to change the PID parameters?

2) The current ArduPilot version in the trunk is stable enough for the SITL simulation?


Leonardo Bueno

Hi Leonardo,

I am seeing very similar effects. Did you have any success so far?



what command did you use to compile the image?

Hi Niklas,

     Had no success so far... I even tried with the stable branch and also with the files from the ArduPlane 2.27 distribution zip as well and it didn't work.



Hi Micheal,

    I've followed the instructions from the wiki:

 cd ArduPlane
-f ../libraries/Desktop/Makefile.desktop

I've tried it multiple times, sometimes using -j 5 flag to speed up the process. Just to make sure the -j 5 was not causing some problem I did one more clean/build right now and the results are the same.



Hi Micheal,

I also tried the current git version and ArduPlane 2.27. For JSBSim I am using the git version from https://github.com/tridge/jsbsim.

I compile with

make -f ../libraries/Desktop/Makefile.desktop

on a Debian Squeeze. Even if I get the plane stable in the air with respect to pitch and roll the yaw axis never stabilizes.



are you on windows or linux?  i have a method that wil lwork for on windows and SITL, but using attitude hil not sensor level hil

I'm on windows using cygwin.



just build using

make -f ../libraries/Desktop/Makefile.desktop hil


and use the normal xplanes hil setup guide

well, I am using both but would prefer linux. I am working on a software that runs on an embedded pc on the drone and interfaces ArduPlane / ArduCopter over the telemetry port using MAVLink. For Debugging and development I just need a simulation that offers me that telemetry port with realistic data. HIL has worked great so far and I would love to use SIL now. If it is easier for now to run the SIL on windows that’s fine and I would be happy to try it and see how far I get.

Building with the hil target failed:

/tmp/ArduPlane.build/libraries/Desktop/support/sitl_barometer.o: In function `_Z21sitl_update_barometerf':
/cygdrive/c/Users/leonardo/Projetos/ardupilot-mega/ardupilot-mega/libraries/Desktop/support/sitl_barometer.cpp:35: undefined reference to `_barometer'
collect2: ld returned 1 exit status

As the hil code probably doesn't uses this, I just commented out the code from sitl_barometer.cpp and managed to build it. Just need to finish the 3Gb download of x-plane now to test it.

nice, this works like a charm. I have the code running on my linux box and x-plane on the windows maschine. I also had the issue with the undefinded ref. to barometer but other than that its fine.

Would love to get JSBSim working on linux equally well. I will play with it a bit more. Thank you very much for the help!

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service