PLEASE HELP. MP can't communicate with APM

Hello  all.

I'm at my wit's end and need help. Last fall, I got my new quad flying and did some tests. I needed to move the compass and do another compassmot, but couldn't get around to it due to school. This spring, I got the quad back out to work on it and can't get it to communicate with MP. It times out each time and gives me a 'No heartbeat packets" error and says it can't open the COM port. The APM 2.5 lights up, the red, blue and yellow lights flash, but it times out every time. I can't even reload the firmware.

Here's what I've tried to do so far, with no luck;

- 4 different USB cords

- With and without the receiver attached

- With and without the new external mag attached

- Quadruple checked the cut I made for the external mag as per instructions on this site

- checked and reloaded the FTDI drivers

- Deleted and reloaded the MP, on 3 different computers (Windows 8.1, Vista and XP)

- With and without power from battery and power module

- With and without external GPS antenna

- With many different versions of MP

- Even tried with APM planner

I'm losing my mind and haven't been able to fly all year. Please help!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi I had similiar the problems the question that I have has this been purchased directly from 3DRobotics or authorized dealer - was this purchased from -on ebay/China/Hong Kong on the gray market. What I found is there a number of "clones" of the APM module and associated hardware - which uses inferior parts. I purchase such a clone and found numerous problems like the one you described.

    I sent it back got a refund and purchased directly from 3dy robotics no problems since then

    Just my experiences

    • Mine was ordered straight through 3DR.

  • Maybe the 3.3 regulator is blown.
    • I've heard of this issue, and hope to god it's not that. I am a broke college student with a kid who plays hockey- Took me a while to be able to buy the APM in the first place, I can't get another for a long time. I've only have 5 test flights on it!

      What are the causes of the blown 3.3 V reg and how can I trouble shoot it?


      • It looks as if the 3.3v regulator problem is mainly affecting nav sensors. Doesn't seem to apply here.

        Any one else have any clue?

  • Admin


    Have you tried using a powered USB Hub yet?


    TCIII Admin

    • Thomas,

      Thanks for the quick reply. I haven't tried that because I read somewhere that you should avoid hubs with APM. I can try that later tonight and post the results.

      Thanks- Jim

      • Thomas-

        Good news and bad. The good news is that before, the double red flash didn't last longer than a few seconds while trying to connect, where as now the double red "heartbeat" flash is on when hooked up to USB.

        The bad news is that I still get a "no heartbeats" error on timeout.

        Any Ideas?

        PS- the way it is hooked up right now is APM > USB cord > powered hub with nothing else plugged in > USB cord > laptop.


This reply was deleted.