Power weirdness questi

Having some weird behavior I hope someone will know about.I have an APM 2 on a quad that has been working fine. Took it out today and it won't initialize. Te board just sits with the amber LED flickering. If I plug in the USB cable from the PC, the bore comes up. If I power it from the battery, it does the flickering amber LED. I power the board from a 5 volt BEC normally. I assumed it was a bad BEC, but when I checked it, it is putting out clean 5V. I tried putting on the jumper and powering the board from the ESCs, but get the same thing. It only wants to work when the USB is plugged in.Any ideas?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Figured it out. 

    I swapped the APM 2 for a 2.5 I have and got exactly the same symptoms - which was doubly weird because even the power connection was different. 

    I unplugged everything and added things in one at a time.

    Turns out something is wrong with my telemetry radio (3DR 915) - when it is plugged in the board will not initialize unless the board is powered by the USB port. If I unplug it, the board works great. When I swapped the radio for a different one, it worked again. 

    Not sure how to go about trying to debug the radio, but at least now I know what happened. 

  • 3D Robotics

    Is that the older APM 2.0 or a 2.5? 

This reply was deleted.


Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23