Prefetching of imageries stopped working

I was using google imagery and there was no issue to prefetch it. But now it has stopped working.

After entering the number of layers (default is 20, I change it to 19) as soon as I click OK I shows a windows error message and the Mission Planner gets closed. I have the latest Mission Planner as I let it update whenever it requires to do so and I have Windows 10 that is also regularly updated. Some update, I don't know either of the Mission Planner or Windows, caused this issue. Any suggestion to resolve this please?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • OK, now I understand this. Many thanks Mike Kelly for these clarifications. I have actually two APM 2.5 boards and now want to get the APM mini as well because the APM is good enough for me (you know the PixHawk is quite expensive). Actually I have never done this firmware update and I don't know yet which firmware is loaded on my boards.

    One last thing (lets hope last) that like the firmware is there any restriction on updating the Mission Planner for APM? (or in future they would say that after this version of Mission Planner the APM would not be compatible with Mission Planner). Is so then I would need to go back to the compatible version (probably you earlier said that some versions create issues with some functions).

  • Thanks Paul Meier

    Paul Meier said:

    firmware is the thing you put on the APM board with the help of mission planner

  • We have two components.

    The flight controller - APM which resides on the aircraft. It runs firmware that is arducopter, in this case version 3.2.1. This firmware controls how the APM hardware functions as a flight controller.

    On the ground we have mission planner, a windows application. It is used to configure the flight controller and receive telemetry from it when it is flying and to send it missions from the ground.

    You must upload firmware for the APM flight controller through mission planner, connected via USB, from the "install firmware" page in Mission Planner. These different versions are for different configurations of aircraft, like quad or hex. The last version for APM was 3.2.1. There will be no more updates for APM it is obsolete hardware replaced by Pixhawk.

    You can tell what version of Mission Planner and the firmware version of the flight controller by connecting to the flight controller via usb and reading the versions off the top line of the mission planner display, after you connect.

  • firmware is the thing you put on the APM board with the help of mission planner

  • I am totally confused now. Is firmware something different than Mission Planner? If so than I have never used this 3.2.1 thing. What do you mean by:

    1. Do not connect? Is it the board or internet?

    2. Set the com port? with what baud rate? Isn't it something required to be connected with the board?

    3. Go to the install firmware page? Where is this page? On Mission Planner?

    If firmware is something different than Mission Planner software then can I keep on updating Mission Planner or again I need an older version for APM 2.5?

    Is Firmware is part of Mission Planner or something to be put on the APM board?

    How do I know which firmware I have?

    My current updated version of Mission Planner is 1.3.41

    Please help me to understand this all or let me know the link where these all details are available.

  • Install the hex file using Mission Planner. Do not connect but set the com port. Go to the install firmware page and use the "custom firmware" button to specify your download file.

  • I am stuck again. Now I cannot find the Firmware 3.2.1 installer at all. I have the already downloaded zipped file but when I extract it I get some folders each having one HEX and one Text file but without any installer or execution file. I don't remember how I did this first time.

  • Correct. APM FC will not run any firmware beyond 3.2.1 so it would not function if you tried to update.

  • I am using APM 2.5. I went back to the manual where it says that APM is a discontinued board. It further says that the firmware is not being updated for APM after version 3.2.1 for copters and 3.3.0 for planes. Therefore I think I should not update the firmware after these versions.

  • Yes, mission planner, unlike some windows software, does not put a lot of stuff in the registry. So you can have multiple versions in their own folders and start them up manually from inside the folder. I need this because I have some systems that only run under certain versions. It makes it easy to go back and check to confirm that something worked in an old version when it does nto work in a new version.

    Just download the zip file and extract it to a folder rather than using the .msi install package.

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…