Problem downloading Arduplane Dataflash Logs

Hey guys, hoping is just me doing something silly, but I am having problems downloading my log files after the recent Arduplane firmware update. We had some AWESOME long range flights this weekend, and I am just gagging to see the logs.

I have been out of it for a while , so here is what I am doing : 

I am connecting the APM 2.5 via usb cable to the latest version of MP.

When I connect with flight data, it connects ok, the Flight data is displayed correctly , the AH moves like it should, I can load new missions via the planner, and change any parameter via the settings screens.

I then disconnect everything, because CLI only works on first connect, then reconnect the usb cable.

I then go to TERMINAL, and click "connect" on the top left. (APM selected).

The APM starts to talk to the terminal, I see a few lines of english , like " Com port opened" etc, but then goes into garbled mess, and CLI does not come up with a menu. (Is CLI still active in Arduplane?)

It looks almost as if mavlink data is coming through, or the baud rate is incorrect, but I have checked the baud rate as 115200. (it works in flight data, remember?

I also tried repeating the above, but NOT clicking on connect, just "Log Download" , but then the log browser appears with much garbled text and beeping.

I have tried different USB cables, Different PCs

Any ideas guys?? (Can supply screenshots if it will help)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • OH. MY. FrIGGIN Goodness.

    How simple can it be, one just needs to know where to look!

    Thank you so much Andreas and Randy, saved me alot of RTFM-ing. this is what happens when you work too hard and dont get enough time to play with the nice toys.

    Regards
    Wessie

  • This is what I get if I click CONNECT

    3701885551?profile=originalAnd this is what I click if I click LOG DOWNLOAD.

    3701885634?profile=original

    https://storage.ning.com/topology/rest/1.0/file/get/3701885551?profile=original
    • Developer

      Wessie,

           This page is for copter but I think the same method will allow you to download logs "using mavlink" even on plane.  You'll also need a recent version of MP with this functionality.

  • Hi Wessie,

    Hope you are well.

    There is no more CLI in Arduplane. You will have to download the log via mavlink on the flight data screen under "Data Flash logs"

    Groete

    Andreas

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…