Hi,

When I try to download a log from my PX4 or use the .bin->.log button the decimal numbers in the .log file are constructed using the decimal separator from the local Windows settings. Trying to load the .log for viewing in MP gives me very weird results like double the number of columns and huge values.

These are some lines from a translated .bin:

INAV, 0,06, 0,09, 0,01, 1,043433, 0,3659202, -0,3779645, -35, -1, -44,52744, -1,593196
IMU, -0,0001223721, 0,0005450109, 0,0003425311, -0,4193751, 0,3476558, -9,802893
MAG, 87, -197, 440, -78, 127, -168, 0, 0, 0
IMU, 0,0004097372, -0,0005192086, 0,0008746404, -0,4169832, 0,3500514, -9,788758
IMU, 0,0004097372, 0,0005450109, -0,0001895782, -0,4253547, 0,3308864, -9,808782
IMU, 0,0004097372, 1,290115E-05, -0,0007216884, -0,4313343, 0,346458, -9,794648
ATT, 0,00, -1,75, 0,00, -3,24, 0,00, 70,33, 70,33
MOT, 1081, 1081, 1081, 1081

I live in the Netherlands so my decimal separator is set to comma.

When I change my local setting to English (US) then the translation is done perfectly, so there is a workaround.

MP version 1.2.66, W7/64 ultimate

Just a small issue, like your tool very much!

Regards, Frank

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    can I get you to test this in the next mp and report back here? I think ive fixed it.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…