Hi All,

I just received my PX4 and PX4IO kit, and am trying to get the autopilot up and running - following this guide to the letter: http://copter.ardupilot.com/wiki/common-load-firmware-px4/

I've successfully used Mission Planner to successfully update (multiple times, confirmed by the files on the SD card saying it started up OK) the firmware in both the PX4 and PX4IO.

It's really interesting that I can update the firmware for the PX4FMU via Mission Planner, however, the issue I keep running into is actually connecting to the board via USB afterwards through the COM port. It just says "Trying to Connect" with the countdown timer, and then will eventually time out if I let the counter run. Tried assigning different COM ports in Windows. Here's the Windows Port Settings:

Bits Per Second: 115200

Data Bits: 8

Parity: None

Stop Bits: 1

Flow Control: None

I've tried uninstalling and reinstalling the COM driver, tried powering through an external hub as I've read that could sometimes cause this issue.

I'm using Mission Planner 1.2.64 mav 1.0, Arducopter 3.0.1 Y6, through a Parallels Desktop Win7 64-bit virtual machine on my latest gen Macbook Pro.

I didn't purchase the 3DR Telemetry radios to go along with it, so I can't try to connect via radio at the moment (regretting not buying those radios now).


Well now this just gets frustrating. I've managed to get it to connect randomly 2-3 times, seemingly by changing the Flow Control to either Xon/Xoff or Hardware. Have not gotten it to connect ever set to "None". But after disconnecting and trying to reconnect, (disconnecting the USB and reconnecting it too), it won't come back.

Any advice?

Views: 3507

Reply to This

Replies to This Discussion


Did you try to connect after reboot the px4fmu. I had a similar issue and i successfully connected after reboot the px4fmu



Yes, tried rebooting both by pulling USB Power and cold starting the px4/px4io, and also by hitting the reset button on the FMU. No such luck - wait for it to get past the boot loader and then try to connect after the buzzer gives the startup sound, but doesn't connect.

Tried another windows machine (32bit Win7 on a HP tower).

Same issues. Oddly, the COM port would get forced to 9600 baud by Windows, and if I would change the windows setting to 115200, it would revert back to 9600 immediately after I hit OK and then reopened the window.

Oddly, I got it to connect a few times at 9600 set in Mission Planner on that machine!

And, back once again to my main Virtual Machine, I got it to connect once at 115200 baud via an external hub..... but then couldn't get it to reconnect again anytime after that.

I've also tried supplying power via the PX4IO input also with no luck.

I'm having the same problem with my PX4 on my normal windows machine (not virtual machine) I can upload the firmware, but I can't connect to it once I unplug and replug it in. I'm running Arduplane v2.74b.

Ian: Have you figured out what the problem was by any chance?

No idea at this point. Have an email into 3DR tech support and a thread on RC Groups as well, but no idea so far.

I'm actually debating about whether to just buy a set of telemetry radios, as I cheaped out and didn't buy those to start, and apparently there's very few issues with that method. (Probably because the radios have a dedicated hardware USB implementation, as opposed to the software one the PX4 does on the main chip?)

The same trouble here - but for me the powered hub workaround solves the problem.

Maybe there is some problem with power usage declaration in the USB device descriptor?


I have found that if you have a full up PX4 module which includes the IO, GPS, and outboard compass, the USB is unable to fully power the whole assembly. I found the voltage supplied to the GPS to be 3.96vdc when using the USB connection. The PX4 looks like it is operating correctly, but it isn't. The solution, as you have described above, is to use a powered USB hub.

I also found that when powering the PX4 assembly with a battery and communicating using the 3DR telemetry radio, the voltage supplied to the GPS was barely 5vdc. I have no trouble establishing a MavLink connection when using the battery and telemetry.


TCIII ArduRover2 Developer

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service