Quad drops alt at random on Auto...

Hi guys,

I had quite a scare today, I was testing out my quad on auto, I've done this before but this time I added more waypoints and differences in altitude for the waypoints.

Everything was going well but halfway through the auto flight, the quad started to drop in altitude continually up to a point where it reached the ground. Thankfully I was keeping a close eye on it and managed to swap back to stabalise mode before it completely crashed.


The above is a screen shot of the Tlog showing how the altitude started to drop consistently after way point 5. I have attached the full Tlog, the crash happens at around 34%.

I tried troubleshooting it myself and here's what I have concluded thus far:

1. Shouldn't be a GPS problem, GPS status in the logs seem consistent

2. Shouldn't be a battery problem as I flew the exact same route on the same battery after this crash and the quad flew the whole route without incident.

3. Shouldn't be the wind, flew a few times in different wind conditions at different locations and with different batteries, and 1 out of 2 times this would happen at a random location

4. Shouldn't be a receiver failsafe problem as I was able to swap back to stabalise after it clipped the ground and flew it back without issues.

I'm out of ideas and I'm not too familiar with the different tlog values to fully understand the graphs. 

My current setup is as follows:

Stock DJI 450 frame, ESCs, motors and 8" props

AMP2 with Sonar, 3DR telemetry, Castle BEC at 5.3V, uBlox GPS, external LEDs

Zippy Compact 3S 3700mah 35C lipos

ArduCopter V2.7.1

Please advise thanks in advance!

2012-08-26 15-34-27.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I flew 4 batteries yesterday with a mixture of Auto and Manual modes, did 4 different missions repeatedly at different altitudes and couldn't replicate the problem I encountered previously.

    Tried with sonar and without, with onboard video and without, new and old batteries, everything flew as it should. I did some very minor changes to the Alt Hold PIDs, I also took everything apart and plugged everything back together, other than that all else equal.

    The only thing I can think of now is that it could be the weather. It was a very hot day when the crash occurred, maybe something was on the brink of overheating. Or maybe it just caught a downdraft. Or perhaps the new batteries needed some running in. Or maybe I had a bad connection somewhere.

    I don't know, only more testing will find the cause I suppose, thanks for the help nonetheless.

  • I just realised I used to be able to download logs even with 2.7.1. I am not sure what changed since then but no matter what I do (remove and reinsert, electrical tape thickness thing, erase and reset) CLI says no data flash.

    I really hope its a firmware issue and not a hardware one...
  • Developer
    Would you have the flash log?
This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25