Quadcopter flips on liftoff


I've seen multiple threads about this topic and have tried most (if not all) documented fixes for this problem.

I build a quadcopter using these parts:

Pixhawk Advanced AutopilotUblox Neo-7M GPS with Compass (not connected)DT750 Hextronic Outrunner 750kvRotorBits QuadCopter Kit With Modular Assembly SystemProps 2pc CW 2 pc CCW Rotation 12" 4.5 pitchCompact 4000mAh 3S 25C Lipo PackAfro ESC 20Amp Multi-rotor Motor Speed ControllerPPM encoder for PWM signal from the 5ch RC controller


From the threads i've gone through, i have:

  • Made sure that the proper motors are attached to pixhawk in the proper manner (shown in the picture).
  • Made sure that the propellers were spinning in the right direction.
  • Made sure that the clockwise and counter clockwise props are on the right motors (seen in the picture).
  • calibrated the accelerometer in mission planner. Values given when on flat ground is

Pitch: (±0.01 - 0.2). Roll: (±0.01-0.4).

  • Ran motor test to see if vibrations/battery affect accelerometer. They do not.
  • tested over grass and flat concrete.
  • Started with Arducopter 3.01, upgraded to 3.2 to see if the problem might be fixed.
  • Radio gives proper outputs and was calibrated.
  • ESC's are calibrated.
  • Made sure it was in + configuration.
  • Ran motor tests.

A couple of comments about the quad:

  • The pixhawk is not centered on the base, its a little off (towards the back towards motor #4).
  • The weight is pretty well distributed but not perfect.
  • starts flipping at about 50% throttle.
  • always flips towards the corner (between 2 arms, could this mean that there is extra pitch and roll?)
  • using 5 channel controller and a ppm encoder for rc. All channels work (1-5) properly.
  • I have logs, no idea how they work but i just downloaded them from the pixhawk using mavlink.

I've tried fixing this problem for 2 weeks but i cannot find anything wrong with the quad. I've looked at multiple forums and all the solutions were not applicable to my quad (usually configuration problem with props/motors). I'd love some help or any suggestions. 

Thank you.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Here is a video demonstration of the motors.

    • Armed and spinning at about 10% throttle.


    • Mission planner motor test order A-B-C-D


    • Ok, Now we need you to remove the props and takeoff to mid throttle and then put it back down.

      This should show an even power on all the motors so we can make sure that it response correctly to throttle input.

      Also we can see the RCIN in action.

      Then tip the copter Left, Right, Down, and then Up.

      shut it down and upload the logs.



      • I'm having issues getting the quad to log. i've tried multiple "flights" with no props and it will not log any of them. Is there a specific way of logging that i'm missing (logging worked this morning).

        I've checked the params and it's set to log nearlyall.

        • Did you remove the Flash card from the Pixhawk and check it on your computer or are you trying to download through mission planner?

          It only starts logging when the copter is armed.


          • It took all day but I finally got a log file. I think it was 3.2 causing the logging to bug. Switching to 3.1 fixed my logging issues (I think). 

            So in the course of the day I rechecked the motors and re calibrated the quad. Unfortunately, the quad legs aren't perfect so the starting pitch/roll are not 0 (they're between -0.4 - 0.4).

            Here is the log (sorry it's so late.)

            2014-12-01 18-56-40 3.log

            • pitch and roll are ok at the level.  They will be off by a little bit.

              The problem is the log is bad.  It maybe that the voltage to the Pixhawk is too low for it to work correctly.  Don't see in stick inputs or motor activity.

              If things are working correctly when you lean the copter to the left that motor should spin faster and when you lean it to the right the motor on right should spin faster.

              Need check that the Pixhawk is starting up ok.




              • I'm currently having trouble with logs. The arducopter does not log any of the flights. I have reinstalled the firmware (3.2 arducopter) after installing arduplane to remove older data. This makes it log the first flight (with missing data such as ATT, IMY, RCIN, ...) and no other log is generated after. I have checked params and it is set to nearly all. I made sure to re-write the param just in case. Problem persists.

                I have returned to 3.1.4- but the same problems continues on this version. I have also tried 3.1.2 and latest firmware of December 2nd 2014. The problem persists. I have tried a flight with propellers as well and the tipping problem is still there and the log for it (after a fresh install and calibration) is missing data. 

                • Not heard of this issue.  Perhaps the Compact Flash card is corrupted.

                  Is it possible to attach it to your computer and reformat it or check to see if there are errors.

                  Needs to be Fat32.




                  • I'm sorry for the wait. I fixed the no logging problem by formatting the sd card and i setting the log maskbit from nearlyall to nearlyall+ AC315.

                    Here is my log of the test (set throttle to 50% and rotate the quad to its sides Left-Right-Down-Up).

                    2014-12-02 20-47-25 9.bin.log

            • My log-interpretation skills are too limited to be useful here.

              I can't see any fault with the Mission Planner motor test in your second video. The wiring appears correct, at least.


This reply was deleted.