Hi everyone, 

I am new to the world of multirotors and thought I would try the PNF Quanum Nova (Cheerson CX20) and use my existing Turnigy 9x receiver and transmitter. 

I have installed everything correctly, all channels are showing up as working and in the correct direction on Mission Planner, and I have calibrated the radio. 

I power on the quad and my transmitter which binds quickly to the receiver. The green light eventually goes solid but no matter what I do, I cannot get the system to arm. 

What I have tried so far:

- First turning on the quad, then waiting for 20 seconds, then turning on the transmitter and putting the throttle stick hard right on lowest throttle for 5 seconds to arm the motors (nothing)

- Turning on the transmitter first, then the quad and trying to arm the motors with hard right and no throttle. 

- Trying to arm through Mission Planner, I get the message "Error: Arm message rejected by MAV"

- Adjusting sub trim on the throttle in case the FM doesn't like the input from my transmitter and won't accept the value as the lowest throttle signal. I tried the reverse of this too to bring it within the 1100-1900 range the values in the calibration mention. 

As far as I can tell, everything else is set correctly. I am completely lost on this one and have spent hours 'googling' to try and find an answer but nothing conventional seems to be working. 

Is there any way to see the actual reason why the FM will not arm the motors, like a log file with some useful information?

Any help would be greatly appreciated. 

Views: 513

Reply to This

Replies to This Discussion

Have exactly same problem. Any ideas welcome.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service