Radio Calibration not recognizing channels 6,7,8

The MP, APM 2.5 setup when using Radio Calibration with my Turnigy 9XR radio, with Open9x firmware, no longer recognizes the Channel/Pots 6,7,8.

The radio works fine and all features work. The radio binds with the receiver. The copter will function by Arming and connect to the MP. MP functions as expected. Settings can be changed and saved. But, the Radio Pots for channels 6,7,8 are no longer recognized or registering in MP to calibrate.

Does any one know how to re-configure PPM to recognize all the channels?

Hardware, Software, Firmware Setup:
* Turnigy 9XR Radio with Companion9X.
* FrSKY D8R-XP using PPM (8 channel)

* FrSKY DJT Transmitter
* APM 2.5 w/firmware 3.1.1 or 3.1.2 --- I can load whichever.
* MP 1.2.98 build 1.1.5190.13206

* OS - Win 8

Classic Problem - IT ALL Worked when I left it a couple months ago. The radio Pots for channels 6,7 and 8 are now not being recognized as I try to Calibrate the Radio.

Scenario/Background

I'd crashed my quad-X a few months ago, rebuilt it, tested it and then let it sit the winter. I tried to fly it again recently after a few months sitting and it wobbled out of control. No problem there - I'd rebuilt after a crash and figured I'd have to recalibrate. So, I upgraded from MP 1.2.7 and firmware 3.1 to the latest MP, as of 3/18/2014 and tried to upload the latest 3.1.2 firmware. The firmware would not load. It gave a communications error of COM/com not found yet the MP w/MAVlink connected with no problem. Here I simply used a different method to load the firmware and went adventurous to use the Beta firmware. Well, that did not play well with the new Wizard and MP. The Com/com error has since gone away. I know not how/why.

Things I have done and tried:

* I have Static (No flight.) Calibrated the Quad with the newer MP and Beta firmware but, features of the Wizard and configurations were not smooth and the BIG issue was that the Radio Calibration did not recognize my Radio Pots - Channels: 6,7,8. I had no RC problems previously as it readily has connected and calibrated over the last year+.

* I've downgraded the firmware from BETA to 3.1.2. This time MP was able to perform the firmware upload with no problem. Well, I still had no radio channels for 6,7,8. 

* I've downgraded to 3.1.1 with the same problem of Radio Calibration.

* I have re-bound the Receiver to the Radio Transmittler.

* I have re-programmed the ESCs, individually.

* I have, using the Radio, re-calibrated the ESCs for the throttle range, as a group. All work via radio.

* I can Arm and DisArm the copter through MP with quick response.

* I can re-calibrate the Radio Firmware for the Pots and the response and range shows properly on the Radio.

The MP indicates all Telemetry via MAVlink when connected too. GPS will lock and the map shows correct location. Compass works and registers correctly. Battery level shows properly and Failsafe for battery and Throttle work. Motors spin on Arm and stop on DisArm. Radio and USB connections work.


Anyone have a solution or clue to the Radio Channels not being recognized or responding?

Brian.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Issue resolved. Solution below ----- By myself - Poster - 4/4/2014.

    In the OpenTX (9XR) transmitter Mixer page the CH6, 7, & 8 s/b P1, 2 & 3, respectively, for the physical POTs. (Then all you guys knew this and I was needing to learn. Thanks.)

    Some time in the upgrades and fixing I'd changed the settings on the 9XR transmitter Mixer Channels 6, 7, & 8 from P1, 2 & 3 to PPM6,7&8, respectively. I had upgraded to PPM sometime ago and had thought that since I'm using PPM it would reflect for the channels. That thought was not correct.

  • bump...

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…