APM unable to read radio

I have assembled an APM1 and IMU from the kit and now I'm trying to configure everything using the Mission Planner software. The firmware uploads (version 2.7) and everything seems to be working (GPS locks and shows location on the map, accelerometers show tilt on the gauge, etc.).

When calibrating the radio the issues start. The sliders in the Mission Planner showing the radio inputs seem to change every once in a while but not to logical values. Moving the sticks on the radio don't change the sliders in the Mission Planner. The radio works fine, tested with servos and also tested a different radio but still had the same issue.

On other threads users have said that soldering errors can cause this. I checked everything on the APM1 and the IMU and the only thing I could find was between the GND pin and the PE6 pin on the IMU. The multimeter showed 0.3 ohms between those two pins, an edited photo is attached to show the pins I'm talking about. Is that normal or have I made a soldering error? A thorough visual inspection of the APM1 and IMU shows no shorts on any of the solder joints for the pins.

Any suggestions on where to go from here would be greatly appreciated! I'm not sure if this is something I've messed up or if the APM1 or IMU is defective (kit was purchased from the store here). Or maybe something else if I'm barking up the wrong tree. Thank you!

possibleShort.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • After extensive troubleshooting I tried a different 1280 based APM with a stripped down ArduCopter 2.6 firmware at which point everything worked perfectly and the radio funkiness was gone (thank you, Chris!). It seems that the multiplexer was bad/fried/possessed. I ordered another 2560 based APM from the store which arrived today and everything is working great with ArduCopter 2.7.1 firmware. This weekend I plan to mount a GoPro HD HERO2 camera and shoot some video. Wish me luck!

  • After flashing the PPM firmware I'm giving up on the APM1. The PPM firmware flashed successfully but the problem did not go away. Time to find another autopilot I guess. Would have been nice to see it fly at least once though.

  • I've tried many things, different power sources (BEC, battery pack, 7805, etc.), different radios, different firmwares, the works. Not sure where to take it from here short of finding a different autopilot because if I can't get past the configuration and radio issues I can't fly with it. Any help would be greatly appreciated.

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…